Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Port forwarding with Belkin/Win 7 for game server


  • Please log in to reply
10 replies to this topic

#1 splittingeve

splittingeve

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:24 AM

Posted 20 January 2014 - 05:31 AM

goal in a nutshell: I'm attempting to help someone (online) to forward a port so they can run a game server.

On the game side of things, I also run a server for this game on my machine (XP Pro with a Linksys E2000), and they can connect to me fine. I mention this to help eliminate questions about problems with the server setup or game itself as we seem to have that process down ok.

The key differences between our setups is they run Win 7, and have a Belkin router (F5D8236-4v3) - both of which I'm not familiar with other than what I've learned over the past couple of days. It could be either, but I suspect the Router settings to be the issue...but Im guessing.

I've been using this page as a visual guide to see what they're looking at as we go; http://screenshots.portforward.com/routers/Belkin/F5D8236-4v3/default.htm , as well as screencaps from them.

The game is called 'Starbound'; http://starbounder.org/Guide:Setting_Up_Multiplayer.


Some of the steps taken so far;

-set up game server essentially as I did on my machine (different in name only)

-set a static IP for their system

-accessed router via browser to open port 21025 (TCP) on their 'virtual servers' page (http://screenshots.portforward.com/routers/Belkin/F5D8236-4v3/Virtual_Servers.htm)

-uninstalled temp version of Norton (which had apparently been controlling firewall)

-set a new rule for the port in Window's firewall (which didn't let me in so...)

-disabled Windows firewall

-disabled router's firewall

-tried changing connection type in router to 'static' (http://screenshots.portforward.com/routers/Belkin/F5D8236-4v3/Connection_Type.htm) - default was dynamic


At this point, they can now run the server successfully, and connect to it via their local machine. Using Portforward's port checker tool as well as online sources, their port still shows as closed though, and no one else can connect. According to the server log, I don't even ping their machine - it's as if no attempt has been made (e.g., if it were a password issue, etc. it would show that I had tried and failed to connect).

So, something is still blocking access and giving at least the appearance of a closed port. There must be some additional steps either with Win 7 or their Belkin router that I'm unaware of, since these steps worked on my machine. It may well be security setting on the router, which I'm not familiar with (my default setting worked find so I never messed with those). Any suggestions would be appreciated! Thx



BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:24 AM

Posted 20 January 2014 - 08:14 AM

Are you both using the same ISP?

#3 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:24 AM

Posted 20 January 2014 - 10:12 AM

I haven't messed with Norton for a while but is it still a bugger to get off your system?


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#4 splittingeve

splittingeve
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:24 AM

Posted 20 January 2014 - 07:14 PM

Are you both using the same ISP?

Yes, we both use Comcast.


I haven't messed with Norton for a while but is it still a bugger to get off your system?

Ha! That's what I was telling him. I recall a terribly intrusive piece of...software. He claims it was a fairly straight forward uninstall though.



#5 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:24 AM

Posted 20 January 2014 - 07:31 PM

Have you tried setting up a static IP on the server?

#6 splittingeve

splittingeve
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:24 AM

Posted 20 January 2014 - 07:36 PM

I'm not 100% sure what you mean. We did set up a static IP on his machine, via the Local Area Connection settings. We then entered that info and the port to be opened in his router settings.

 

The server config file itself doesn't have such an option by default. I also run this game's server on my machine without issue, though are config files are essentially identical (we have a different name for the server, 'bout it).



#7 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:24 AM

Posted 20 January 2014 - 07:44 PM

I run my own half life server, and I have to pass on the command line a -ip switch to tell it what IP to bind to, and I use steam. So you maybe lucky enough where you do not need to specify an IP, however, on his machine you may need to do that in the config file.

#8 splittingeve

splittingeve
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:24 AM

Posted 20 January 2014 - 07:47 PM

I run my own half life server, and I have to pass on the command line a -ip switch to tell it what IP to bind to, and I use steam. So you maybe lucky enough where you do not need to specify an IP, however, on his machine you may need to do that in the config file.

Gothca. Definitely a possibility (i may just be lucky indeed), I'll investigate that a bit more cloesly. Should be easy enough to add if needed. Thanks for the suggestion.



#9 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:24 AM

Posted 20 January 2014 - 07:58 PM

Also take a look here: http://www.reddit.com/r/starbound/comments/1s4l04/servers_and_you_getting_started_guide/ Yu may need more ports open.

#10 splittingeve

splittingeve
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:24 AM

Posted 20 January 2014 - 08:01 PM

Holy... Thanks man, thats a whole lotta' info I didn't have. I'll def consult this tomorrow when we give it another go. Appreciate it.



#11 technonymous

technonymous

  • Members
  • 2,490 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:24 AM

Posted 22 January 2014 - 08:01 PM

First you need to change the Wan back to dynamic for Comcast. Assuming the tcp port is properly port forwarded to the correct internal lan IP you Also, might need to turn off Block Anonymous Internet Requests or it might be called just Block WAN Request  in the router. This makes you pingable. You shoudln't leave the firewall off turn it on and just set the same tcp port in there in/out as you did with the router.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users