Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wmpnetwk.exe --- WTF!


  • Please log in to reply
5 replies to this topic

#1 bobthecar

bobthecar

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 14 January 2014 - 03:22 PM

I've been trying all day to stop this process from running on startup. I've disable WMP and I've disabled the process in services. It still returns on startup with 50% cpu usage 500mb ram.

 

When i right click on the process in task manager it tells me the path is :  C:\Users\Gavin\AppData\Roaming\Microsoft\Windows\Recent\wmpnetwk.exe   

 

But there is nothing in this folder...Also i copied and pasted that path in windows explorer and it opened this in command line:

 

 

It flashed on my screen very briefly and I took a print screen of it

 

weird.png

 

 

 

I have no idea what that is, but it doesn't look like its related to windows media....


Edited by hamluis, 14 January 2014 - 05:24 PM.
Moved from Win 7 to Am I Infected - Hamluis.,


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,658 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:00 PM

Posted 14 January 2014 - 03:35 PM

It's the Media Player Network Sharing Service. Disable it in services. http://www.mydigitallife.info/how-to-disable-windows-7-media-player-network-sharing-service-wmpnetwk/

#3 bobthecar

bobthecar
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 14 January 2014 - 04:00 PM

Hi John, thanks for the reply, I have actually followed this guide before posting and it didnt stop wmpnetwk.exe from running. Infact it no longer appears on the local services list, but task manager shows it still running.

 

Previously to posting i have tried typing this in command line "sc delete "wmpnetworksvc"  ", the command told me it was successful in removing it but its still there.



#4 Kilroy

Kilroy

  • BC Advisor
  • 3,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:03:00 PM

Posted 14 January 2014 - 04:07 PM

From the screen shots looks like your machine is mining virtual currency, jhprotominer.exe is a trojan .  If this isn't you then you need to look at cleaning your machine.



#5 JohnC_21

JohnC_21

  • Members
  • 23,658 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:00 PM

Posted 14 January 2014 - 04:09 PM

Download AutoRuns and see if there are any references to it in Services or Logon. Don't delete it, just uncheck the box. wmpnetwk.exe is located in C:\programs files \Windows Media Player

 

Edit: Thanks for that info Rkilroy.


Edited by JohnC_21, 14 January 2014 - 04:11 PM.


#6 bobthecar

bobthecar
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 14 January 2014 - 05:12 PM

Thanks guys, problem solved. It was a trojan as you said, pretending to be a useless service i dont want, strange world.... Gone for good now, wonder if the culprit made many virtual coins off my unwilling CPU. I'll never know.

 

Have a good day =)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users