Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 8.1 low memory/BSOD with Driver_Not_Equal


  • Please log in to reply
6 replies to this topic

#1 Grammaton485

Grammaton485

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:12 AM

Posted 14 January 2014 - 01:30 AM

Gents,

After updating to Windows 8.1 last October, I've found that certain games in my collection will force my computer to crash. The message displayed is driver_not_less_or_equal igdk igdkmd64.sys. After some research, I've discovered that this is the Intel HD 4000 graphics driver (full system specs listed at the bottom of this post). From what I gather, there is a significant issue with Intel graphics and the 8.1 update. There have been multiple reports of low memory and driver crashes.

 

This happens with several games, but I will be using Kerbal Space Program as an example. The game loads and runs fine. I recently even dialed back the resolution to match my computer monitor, and that didn't help. Partway into the game, I'll hear a Windows notification chime indicating low memory, and my computer blue screens with the above message. I've gotten the low memory chime on other games with no crash. Prior to adjusting the screen resolution, the game would simply crash without the low memory warning.

 

Microsoft was unwilling to help me in their support forms, as they were simply pointing people towards Intel drivers. Intel is aware of the problem, and has released their newest drivers, but these have been met with no success from any of the interested parties (I currently am using Driver 3308, and they have since released 3316 and 3345, but installing them is next to impossible). I have not seen any further developments for weeks on their end. Since this site helped me with a nasty virus a few years back, I'm hoping you can help me again.

 

So system specs...

 

Asus R500VD

CPU: Intel Core I7 - 3630QM, 2.4GHz

RAM: 8GB

OS: Win 8.1

HDD: 1TB

 

Graphics: Intel HD 4000, driver ver. 10.18.0010.3308

                Nvidia Geforce 610m 2GB, driver ver 332.21

 

Link to my skydrive with a dmp after a crash in KSP, along with dxdiag. Let me know if there is anything else you need.

 

https://skydrive.live.com/?mkt=en-US#cid=7D80CC67A6BC9A03&id=7D80CC67A6BC9A03!142

 

EDIT: and just to clarify, I have my Nvidia card set to be the default card under global settings.


Edited by Grammaton485, 14 January 2014 - 03:49 AM.


BC AdBot (Login to Remove)

 


#2 Anshad Edavana

Anshad Edavana

  • BC Advisor
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:42 PM

Posted 14 January 2014 - 04:05 AM

Hi

 

As a first step, please try setting Nvidia GPU as the default graphic processor for all apps. To do that, follow step 1 to 8 of the below guide.

 

 
If the BSOD continues, i would recommend running all offending programs in Windows 7 compatibility mode. Please refer option two of the below guide.
 
 
Certain games are not compatible with "Win 8.1" and may cause BSOD. League Of Legends is an example which can be fixed by running on compatibility mode. 


#3 Grammaton485

Grammaton485
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:12 AM

Posted 14 January 2014 - 04:12 AM

 

Hi

 

As a first step, please try setting Nvidia GPU as the default graphic processor for all apps. To do that, follow step 1 to 8 of the below guide.

 

 
If the BSOD continues, i would recommend running all offending programs in Windows 7 compatibility mode. Please refer option two of the below guide.
 
 
Certain games are not compatible with "Win 8.1" and may cause BSOD. League Of Legends is an example which can be fixed by running on compatibility mode. 

 

 

As I mentioned in my post (after an edit, at the very end), the Nvidia card is already the default. I did have to set it to peformance, instead of quality. The rest of the steps aren't applicable, as this has nothing to do with Serato video, and the UI for the Intel Properties is now different. I will try again.



#4 Anshad Edavana

Anshad Edavana

  • BC Advisor
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:42 PM

Posted 14 January 2014 - 06:48 AM

Hi

 

Serato is just an example. What you need to do is follow the same steps for all the problematic apps/games.



#5 Grammaton485

Grammaton485
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:12 AM

Posted 14 January 2014 - 05:46 PM

So far, Kerbal Space Program has worked after adjusting the graphics settings. I was able to play for about 2 hours with no crashes, as opposed to a few minutes with a BSOD. I will try other games that have crashed.

 

So I'm curious, what would setting the graphics properties to 'performance' have to do with anything? Is this to produce less strain on the computer and preserve the memory available?



#6 Anshad Edavana

Anshad Edavana

  • BC Advisor
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:42 PM

Posted 14 January 2014 - 11:55 PM

Hi

 

By default, laptops with switchable graphics will use "Intel HD Graphics" for normal operations and it is supposed to switch to the dedicated GPU when a game or a graphic intensive app is opened. But sometimes this won't happen and games are forced to run on Intel graphics which is not designed to handle games (also it uses shared system memory). I don't know the exact reason but so far it seems like bad programming on the Intel driver which is responsible for the switching. By changing the settings, we are forcing the games to use Nvidia GPU all the time which is designed to handle games and came with dedicated video RAM. Naturally there is a less chance for BSOD.



#7 Grammaton485

Grammaton485
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:12 AM

Posted 15 January 2014 - 12:45 AM

Hi

 

By default, laptops with switchable graphics will use "Intel HD Graphics" for normal operations and it is supposed to switch to the dedicated GPU when a game or a graphic intensive app is opened. But sometimes this won't happen and games are forced to run on Intel graphics which is not designed to handle games (also it uses shared system memory). I don't know the exact reason but so far it seems like bad programming on the Intel driver which is responsible for the switching. By changing the settings, we are forcing the games to use Nvidia GPU all the time which is designed to handle games and came with dedicated video RAM. Naturally there is a less chance for BSOD.

 

Okay, thanks for the info. I know one of Intel's issues they mentioned in their support thread was drivers being forced to uninstall, despite having them set as the main graphics cards.

 

Contagion, another game that crashed nearly immediately after startup, worked for a full hour, though I did get a low memory warning. No BSOD. I played Left 4 Dead 2 for about 2 hours tonight with a friend, and that didn't even generate a low memory warning. I will try System Shock 2 when I can, as that was a source of another crash.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users