Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

script on this page is busy error message


  • Please log in to reply
6 replies to this topic

#1 godzilla1347

godzilla1347

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:02:54 AM

Posted 13 January 2014 - 02:06 AM

I am running xp on a Dell Dimension 8200o with 1 GB of RAM and 2.5 Ghz processor. I wasn't getting Windows updates and that was fixed and they're working now. The problem I now notice is that I'm getting "Script on this page is busy" messages now and things have slowed down to a crawl when this happens. Often this happens even when the performance seems normal in task manager. Eventually, the scrips go through if I keep hitting the continue button. I have no viruses or malware as per my anti-virus program, Total Ddefense and I have used Ccleaner to get rid of the garbage but the script errors keep coming. I wasn't getting them before the Windows Updates were fixed.


Edited by hamluis, 15 January 2014 - 10:28 AM.
Moved from XP to Web Browsing/Email, etc. - Hamluis.


BC AdBot (Login to Remove)

 


#2 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:01:54 AM

Posted 13 January 2014 - 05:00 AM

What browser are you using?



#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,385 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:54 AM

Posted 13 January 2014 - 09:01 AM

Worth a look, IMO:  Error message A script on this page is causing Internet Explorer to run slowly - http://support.microsoft.com/kb/175500 .

 

Louis



#4 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:02:54 AM

Posted 13 January 2014 - 12:15 PM

I'm using firefox.It doesn't mention IE and I'm not using it.  I will check out Louis's suggestion. It also happens with Word when I'm not online.



#5 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:02:54 AM

Posted 14 January 2014 - 04:30 PM

The exact error message is Warning! Unresponsive Script.   It then states a script on this page may be busy or may have stopped responding. You can stop the script now or you can continue to



#6 hamluis

hamluis

    Moderator


  • Moderator
  • 56,385 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:54 AM

Posted 15 January 2014 - 10:27 AM

See https://support.mozilla.org/en-US/kb/warning-unresponsive-script .and http://kb.mozillazine.org/Unresponsive_Script_Warning .

 

Louis



#7 godzilla1347

godzilla1347
  • Topic Starter

  • Members
  • 347 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island, NY
  • Local time:02:54 AM

Posted 12 February 2014 - 01:59 AM

Thanks, I just got back to this. It appears that as this xp computer only has 1 GB of memory and new webpages require more memory to load properly than when this computer was born--certain sites simply take a long time to load on this system. I had noticed from Hamluis' post that i could modify the about:config preferences in Firefox to increase the timeout number. By increasing it from 10 to 20, this problem seems to have been eradicated.  I also noted that it only has come up in two sites: Web of trust--which is a useful tool as it identifies garbage sites. However, it was hanging my system so when I got rid of it, half my unresponsive script errors disappeared. The other half were the fault of Optimum webmail's new interface, which takes a year to load on this system. As a result, the loads are way longer than required on other sites. So now that I've increased the timeout in preference, this too seems to no longer be a problem (other than it takes about 30 seconds to load the applet).

 

Probably I could have also solved the problem if I had bought more memory but as XP is going into hackerland on 4/8/14, this computer is going to be pulled off the internet before that time and sent to pasture, so there's no point investing another $150 in memory to bring it up to the max 2000 GB. 

 

In any case, the timeout fix seems to have worked.  The interesting thing is the creeping memory requirements as sites get larger and more data intensive. When this computer first came out, it was top shelf. Now its the Commodore 64 of its day.

 

It's a shame too because I like XP and would never have needed anything more. . . other than memory enhancements to keep up with the creeping, expanding sizes and complexity of websites.  I guess that's why cowboys had a hard time switching from horses to cars.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users