Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 8.1 Update Error During Install (irql_not_less_or_equal)


  • Please log in to reply
No replies to this topic

#1 jFolis

jFolis

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:34 PM

Posted 06 January 2014 - 06:32 PM

Hi guys. I'm usually one to find my solutions in forums and never actually post, but this time I'm sort of stuck. Between Microsoft not giving me a lot of info to go on and the wide range of "possibilities" here, I'm not sure what to do.

 

Here's what's up. I was running Windows 8 Pro x64 with my OS installed on a 128gb SSD and my user files located on a separate hard drive. This was done after a good amount of research and by following a step by step tutorial. It worked/works fine in this configuration and I've never had a problem.

 

As everyone in my position found out, 8.1 requires the user files to exist on the same drive as the OS, effectively making my configuration impossible to update to 8.1. I figured I'd just wait it out and see if someone found a workaround and, lo and behold, people have. I used the one explained here: http://answers.microsoft.com/en-us/windows/forum/windows8_1-windows_install/sorry-it-looks-like-this-pc-cant-run-windows-81/16800fc9-700b-42d0-a210-d07630698ed6

 

 

How to update a system with a relocated data drive to Windows 8.1.

This recipe is the result of cumulative knowledge from the Microsoft Community.  My thanks to PC WOW Corp, Geonk and many others who did all the hard work.

  1. If it does not exist create folder C:\Temp
  2. If it does not exist create folder C:\Users
  3. Go to Libraries\View ensure that “File name extensions” and “Hidden items” are both ticked
  4. If folders C:\Users\Default or C:\Users\Public are not present, copy them into C:\Users from whichever drive currently contains the Users folder
  5. Select “Start” screen.  Type regedit press enter. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList select File\export and save as (e.g.) plist in C:\Temp
  6. You will see that some of the registry entries will be pointing to your data drive (e.g. d:\Users\Default, d:\Users, d:\Users\Public) you may have a different drive letter to d:.  Replace the d: with %SystemDrive%.  E.g. %SystemDrive%\Users\Default
  7. Delete all registry entries in ProfileList beginning S-1-5-21-
  8. Close regedit
  9. Go to Settings\Control Panel\User Accounts\Manage another account\Add a new user in PC settings
  10. Create a new local user account tempusr
  11. Change tempusr account type to “Administrator”
  12. Log out of all accounts.  Log into tempusr
  13. Go to Microsoft Store, download and install 8.1
  14. When complete, restart and log in as tempusr
  15. Select “Start” screen.  Type regedit press enter. Go to File\Import and import C:\Temp\plist
  16. Log out of tempusr and log into your original account
  17. You can now delete tempusr. 
  18. If you did not have folders C:\Temp or C:\Users in the first instance, you can now delete them but you will have to change the permissions on all the subfolders to do it.  This step is optional.

 

At this point I'd like to clarify that everything was and is still working fine on my Windows 8 install. I got to step 13 just fine, but that is where the problem has occurred.

 

Here's the issue:

 

  • The install goes along just fine up through "Applying System Settings" (wording might be off). It hits 100% and then triggers a restart, which I'm assuming is normal behavior. Upon restarting, I run through the bios screens and go back to the spinning Windows balls and suddenly I get a BSOD. It's the simplistic one with the :( on it, and all it gives me is "IRQL_NOT_LESS_OR_EQUAL".
  • The system then restarts and "Attempts to Recover Installation". Once it does that, it gives me the same BSOD with the same error.
  • The system restarts again, restores my Windows 8 install, and I'm back where I was.

 

I followed instructions to set minidump (http://www.carrona.org/setmini.html) and ran through the install again (with the error at the same spot), but no minidump was generated.

 

Like I said, at this point I just have no idea what to do. Googling "IRQL_NOT_LESS_OR_EQUAL" in my context gives me only mild help. It makes me think this might be related to drivers. Thus, I went ahead and updated everything I could to Windows 8.1 compatible drivers (BIOS flashed as well). Still same thing.

 

I'm attaching my system specs, but (like I said) I have no minidumps to offer :( . There's no minidump directory on the drive root, and the only minidumps in the C:/Windows/minidump/ directory are from a driver install issue I was having earlier today.

 

Soooooo, any help would be GREATLY appreciated. I apologize in advance if there's some simple solution I missed!

Attached Files



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users