Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

necessary or not


  • Please log in to reply
2 replies to this topic

#1 fadi-sheikh

fadi-sheikh

  • Members
  • 240 posts
  • OFFLINE
  •  
  • Local time:04:21 AM

Posted 04 January 2014 - 08:29 PM

can I safely uninstall the old versions

Microsoft Visual C++ 2005 Redistributable        8.0.59193
Microsoft Visual C++ 2008 Redistributable - KB2467174 - x86 9.0.30729.5570           9.0.30729.5570
Microsoft Visual C++ 2008 Redistributable - x86 9.0.21022           9.0.21022
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17           9.0.30729
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.4148            9.0.30729.4148
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161            9.0.30729.6161
Microsoft Visual C++ 2010  x86 Redistributable - 10.0.40219          10.0.40219

MSXML 4.0 SP2 (KB954430)       4.20.9870.0
MSXML 4.0 SP2 (KB973688)       4.20.9876.0
MSXML 4.0 SP3 Parser      4.30.2100.0
MSXML 4.0 SP3 Parser (KB2758694)        4.30.2117.0
MSXML 6.0 Parser       6.10.1129.0

Microsoft .NET Framework 1.1            
Microsoft .NET Framework 2.0 Service Pack 2        2.2.30729
Microsoft .NET Framework 3.0 Service Pack 2        3.2.30729
Microsoft .NET Framework 3.5 SP1     
Microsoft .NET Framework 4 Client Profile           4.0.30319
Microsoft .NET Framework 4 Extended  



BC AdBot (Login to Remove)

 


#2 thenneberry

thenneberry

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:07:21 AM

Posted 04 January 2014 - 08:50 PM

You can uninstall the older versions, but if the softwares you are using on the system, requires any of these programs, you will get an error indicating it 'can not find a file' or 'you need this program to run this software'. If you get any of these errors, simply install what is needed for the programs to be able to run. Thomas



#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,552 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:21 AM

Posted 05 January 2014 - 10:41 AM

I would not uninstall any of the Visual C versions, since applications will call for a particular version and if such is not evident...it produces errors in Event Viewer.  In particular the 2005 version has produced such errors on systems I've recently reviewed here in the forums when it is absent.

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users