Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Malware, most programs give Parameter is incorrect


  • This topic is locked This topic is locked
2 replies to this topic

#1 MikeTom

MikeTom

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 03 January 2014 - 05:01 AM

Hi all

 

I have a Lenovo X201 notebook PC running Windows 7 Pro (x64) (also has Avast).

 

Before things went totally wrong I had some odd signs (may be unrelated):

- computer stopping (like a hard switch off) when doing computation intensive stuff like circuit simulations (fan would start running faster, and then turned off) or too many programs running.

- annoying Acrobat Reader Update at startup that would never actually execute when I selected it, seemed to fail.

 

Suddenly things degenerated on the 31st of december, right after installing Samsung Kies (unrelated coincidence?) :

- on boot I get errors for Acrotray.exe and ipoint.exe, and for PrivateIconClient.exe I get error unable to load Jit Compiler, Intel Management and Security has stopped running

- all printers are gone and USB wireless mouse gone (but USB working)

- I can no longer launch most programs from the taskbar or from shortcut icons (I would get a message "incorrect parameter" and then the choice of deleting the shortcut), though some of those apps would launch if I went straight to the location of the exe file.  If I try running Mozilla I get could not load XPCOM. I can run Google Chrome.

- I cannot install or uninstall programs.  I cannot disable or remove Avast

- If I download an exe, I can execute it if I do it right after download, but whatever evil is in  there quickly catches up and mucks things. Changing the filename of executable sometimes helps make them launchable, if I do it fast.

- before running any scans I tried backing up some files to NAS (stupid?), on some files I got Error 0x800700E1 file contains a virus for some files

 

 

In SAFE MODE I can launch programs normally, but I cannot uninstall or install and Security Center is off (I think this is normal in safe mode). 

 

I ran the following sequence:

- Kaspersky TDSSkiller - nothing found

- ran Rkill

- ran Malwarebytes (have log if needed), found and quarantined :

     Worm.Waledac 3 on my accounting software download files (probably been there for a while)

     PUP.Optional.Softonic.A on a download (looks harmless?)

     PUP Adware.Installer on a download of 7zip.exe (looks harmless?)

- ran Hitmanpro, found mostly ad cookies

- ran RogueKiller, found:

 PUM    HJ POL    HKLM\[...]\System DisableRegistryTools - Deleted

 PUM    HJ POL    HKLM\[...]\WOW6432Node\[...]\System DisableRegistryTools - 0x2 file does not exist

(these two were also in the other 2 PCs on the same network - I ran RogueKiller to remove the two PUMs and they seem fine now.) ON THE INFECTED NOTEBOOK EVEN AFTER REMOVAL BY ROGUEKILLER THESE PUMs keep reappearing at each boot in Normal Mode (but not in Safe Mode)

- ran ADW Cleaner

- ran Junkware Removal Tool

- ran ESET Online Scanner

- ran Emsisoft EmergencyKitscanner

 

Somewhere along there I found (sorry, lost track of things out of frustration):

- Win32/Adware.Error attached to old download registryfix.exe 

- Win32:Dropper-gen and Win32:Malware-gen and Somoto-F

 

Sorry about not doing all this in a structured way, frustration got in the way.

 

PC is in sorry shape, would love to avoid reinstall of Windows, especially because laptop does not come with CD, Preinstall is on disk (corrupted too?).

 

I ran DDS, attached logs.  

 

Would appreciate some help!  

 
thanks in advance
 
Mike
 
 
 
 

Attached Files



BC AdBot (Login to Remove)

 


#2 HelpBot

HelpBot

    Bleepin' Binary Bot


  • Bots
  • 12,658 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:22 PM

Posted 08 January 2014 - 05:05 AM

Hello and welcome to Bleeping Computer!

I am HelpBot: an automated program designed to help the Bleeping Computer Staff better assist you! This message contains very important information, so please read through all of it before doing anything.

We apologize for the delay in responding to your request for help. Here at Bleeping Computer we get overwhelmed at times, and we are trying our best to keep up. Please note that your topic was not intentionally overlooked. Our mission is to help everyone in need, but sometimes it takes just a little longer to get to every request for help. No one is ignored here.

To help Bleeping Computer better assist you please perform the following steps:

***************************************************

step1.gif In order to continue receiving help at BleepingComputer.com, YOU MUST tell me if you still need help or if your issue has already been resolved on your own or through another resource! To tell me this, please click on the following link and follow the instructions there.

CLICK THIS LINK >>> http://www.bleepingcomputer.com/logreply/519466 <<< CLICK THIS LINK



If you no longer need help, then all you needed to do was the previous instructions of telling me so. You can skip the rest of this post. If you do need help please continue with Step 2 below.

***************************************************

step2.gifIf you still need help, I would like you to post a Reply to this topic (click the "Add Reply" button in the lower right hand of this page). In that reply, please include the following information:

  • If you have not done so already, include a clear description of the problems you're having, along with any steps you may have performed so far.
  • A new DDS log. For your convenience, you will find the instructions for generating these logs repeated at the bottom of this post.
    • Please do this even if you have previously posted logs for us.
    • If you were unable to produce the logs originally please try once more.
    • If you are unable to create a log please provide detailed information about your installed Windows Operating System including the Version, Edition and if it is a 32bit or a 64bit system.
    • If you are unsure about any of these characteristics just post what you can and we will guide you.
  • Please tell us if you have your original Windows CD/DVD available.
  • Upon completing the above steps and posting a reply, another staff member will review your topic and do their best to resolve your issues.

Thank you for your patience, and again sorry for the delay.

***************************************************

We need to see some information about what is happening in your machine. Please perform the following scan again:

  • Download DDS by sUBs from the following link if you no longer have it available and save it to your destop.

    DDS.com Download Link
  • Double click on the DDS icon, allow it to run.
  • A small box will open, with an explanation about the tool. No input is needed, the scan is running.
  • Notepad will open with the results.
  • Follow the instructions that pop up for posting the results.
  • Close the program window, and delete the program from your desktop.
Please note: You may have to disable any script protection running if the scan fails to run. After downloading the tool, disconnect from the internet and disable all antivirus protection. Run the scan, enable your A/V and reconnect to the internet.

Information on A/V control can be found HERE.

As I am just a silly little program running on the BleepingComputer.com servers, please do not send me private messages as I do not know how to read and reply to them! Thanks!

#3 HelpBot

HelpBot

    Bleepin' Binary Bot


  • Bots
  • 12,658 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:22 PM

Posted 13 January 2014 - 05:10 AM

Hello again!

I haven't heard from you in 5 days. Therefore, I am going to assume that you no longer need our help, and close this topic.

If you do still need help, please send a Private Message to any Moderator within the next five days. Be sure to include a link to your topic in your Private Message.

Thank you for using Bleeping Computer, and have a great day!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users