Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Computer will not go to sleep


  • Please log in to reply
13 replies to this topic

#1 lti

lti

  • Members
  • 592 posts
  • ONLINE
  •  
  • Local time:09:50 PM

Posted 29 December 2013 - 02:45 PM

My Toshiba Satellite L750 laptop will not go to sleep anymore. It is running Windows 7 Home Premium. There were no hardware or software changes I made that caused this, but something could have automatically updated to a version that does not work properly. When I close the lid or let it go to sleep automatically, it will wake up a second later.

 

http://speccy.piriform.com/results/pbqAke1FcCpZB4YIqjFi08U

 

I don't see anything preventing it from going to sleep in the power options. I have looked at all of the options listed here:

http://support.microsoft.com/kb/976877

 

The only device that is allowed to wake the computer is the Ethernet controller, but I am using a wireless connection and wake on LAN is disabled in the BIOS. The mouse and keyboard were allowed to wake the computer, but I disabled that option. Sleep did work at one point with the keyboard and mouse allowed to wake the computer. This is something that only started recently. I first noticed this last week.


Edited by lti, 29 December 2013 - 02:48 PM.


BC AdBot (Login to Remove)

 


#2 Greg62702

Greg62702

  • Banned
  • 717 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:50 PM

Posted 29 December 2013 - 05:56 PM

Check OS side. Something is causing it to wake up in the OS.

#3 lti

lti
  • Topic Starter

  • Members
  • 592 posts
  • ONLINE
  •  
  • Local time:09:50 PM

Posted 29 December 2013 - 09:57 PM

That's why I'm in the OS forum.

 

Every method to put this computer to sleep (automatically after a period of inactivity, through the start menu, or by closing the lid) results in the computer going to sleep, then immediately waking up.



#4 Scoop8

Scoop8

  • Members
  • 326 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas TX
  • Local time:10:50 PM

Posted 30 December 2013 - 09:16 AM

That's why I'm in the OS forum.

 

Every method to put this computer to sleep (automatically after a period of inactivity, through the start menu, or by closing the lid) results in the computer going to sleep, then immediately waking up.

 

I had something similar but not exactly the same symptoms as you're seeing with your Laptop.  I also own a Toshiba Laptop (L655-S5168 model) (Win 7 x64).

 

Check to see if you may have something that's requesting your Laptop to remain awake, or awaken after receiving a Standby command.

 

Launch CMD in Admin mode:

 

- Start menu, type cmd in the search field, right-click and run as Admin.

 

In the cmd window, enter this:

 

powercfg /requests

 

You'll see info that should resemble these screencaps.  I selected 2 to show the differences when an app, program, etc, is requesting my PC's power config scheme.  The 2nd screencap shows that I'm using a video streaming app.

 

The 1st screencap was captured after I had closed the streaming app.  This is what you will ideally see if there's no internal or external objects that may prevent the PC from being put into a Standby mode.

Attached Files


Edited by Scoop8, 30 December 2013 - 09:16 AM.


#5 lti

lti
  • Topic Starter

  • Members
  • 592 posts
  • ONLINE
  •  
  • Local time:09:50 PM

Posted 30 December 2013 - 11:25 AM

I see "None" in all three categories, just like the first screenshot.



#6 Scoop8

Scoop8

  • Members
  • 326 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas TX
  • Local time:10:50 PM

Posted 30 December 2013 - 06:16 PM

Try this in CMD (attached below) and see if it may give a clue as to what's waking your Laptop up.  My results are saying that my keyboard (via USB) woke up my PC as normal.

 

Here's a link to the Windows 7 Forum about the Sleep/Wake issues that others have encountered.  It's a long thread but hopefully there's some info that may help you.

 

Windows 7 Forum - Power Options and Sleep Mode Problems

 

Unfortunately there are numerous possibilities with this sleep/wake issue.  The source of the problem can range from a driver needing to be reinstalled to another PC in one's Homegroup network. 

 

From the description of your problem, it may be that you have an intermittent lid switch.  Sometimes it turns out to be a less-complex solution with these kinds of issues.

 

I had an issue with my Laptop once where it was not going into Sleep mode after the preset "inactivity" timeout value in the Control Panel.  The Laptop was being kept awake by my Dekstop PC via the Homegroup network.

 

I used the "override" parameter in the Powercfg (CMD) mode:

 

powercfg -requestsoverride

 

usage, ie, if PC is waking up without a user input:

 

Usage: POWERCFG -REQUESTSOVERRIDE <CALLER_TYPE> <NAME> <REQUEST>
<CALLER_TYPE> Specifies one of the following caller type: PROCESS, SERVICE, DRIVER. This is obtained by calling the POWERCFG -REQUESTS command.

<NAME> Specifies the caller name. This is the name returned from calling POWERCFG -REQUESTS command.
<REQUEST> Specifies one or more of the following Power. Request Types: Display, System, Awaymode.

Example: POWERCFG -REQUESTSOVERRIDE PROCESS wmplayer.exe Display System

 

 

 

Attached Files



#7 lti

lti
  • Topic Starter

  • Members
  • 592 posts
  • ONLINE
  •  
  • Local time:09:50 PM

Posted 30 December 2013 - 09:33 PM

That command gives me "Wake History Count - 0."

 

I tried closing the lid and letting it go to sleep so I could see what was waking it up, and it stayed asleep.

 

The items at the top of the window in this screenshot are the menu items that appear when the Fn key is pressed (print screen is Fn+End on this laptop). Sometimes they appear in the screenshot and sometimes they don't. I ran the command a second time after opening the lid.

Attached Files


Edited by lti, 30 December 2013 - 09:33 PM.


#8 Greg62702

Greg62702

  • Banned
  • 717 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:50 PM

Posted 31 December 2013 - 10:41 AM

Keep in mind, that it can take 10 to 20 minutes, before the computer may go to sleep.  Look on Support.toshiba.com for a older AHCI or ACPI driver for your machine.

 

I never place any of our machines in sleep mode, unless it is on battery power.  Otherwise, it is complete shut down.  We started seeing this issue, when Windows XP SP3 rolled out, regarding machines no longer going into Sleep mode.  That issue stuck around with Windows 7 SP1 and is still there with Windows 8.x.



#9 Scoop8

Scoop8

  • Members
  • 326 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas TX
  • Local time:10:50 PM

Posted 31 December 2013 - 12:13 PM

I always use the Sleep mode since I have unattended tasks that run overnight, AV scans, etc. 

 

After I had to track down the one issue on my Laptop a couple of years ago where my Homegroup was not allowing it to go into Sleep mode when using the Timeout (Control Panel) setting, I've not had any issues with Standby on my Desktop or Laptop PC's but Greg62702, you're sure right about this Sleep topic being active (intermittent issues, threads, blogs about the subject).

 

If I wasn't using Windows Task Scheduler nightly to run unattended scans, I might be doing the same, using the shutdown when attended activities are completed.

 

I've been using a hotkey to call the Standby DLL to put my PC's into Sleep mode.  I use <win> s to put the PC to sleep when I'm done with my activities.



#10 Greg62702

Greg62702

  • Banned
  • 717 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:50 PM

Posted 31 December 2013 - 04:29 PM

Most newer machines, will allow you to set in the bios, to wake up on a "Magic Packet", for scheduled tasks.



#11 Scoop8

Scoop8

  • Members
  • 326 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas TX
  • Local time:10:50 PM

Posted 31 December 2013 - 05:22 PM



Most newer machines, will allow you to set in the bios, to wake up on a "Magic Packet", for scheduled tasks.

 

2qi4ppz.jpg      

 

I have the Wake On Lan enabled and use the Packet in a "file copy" script to wake my Laptop from the Desktop PC to copy some files to the Laptop.

 

I use Task Scheduler for the nightly AV scans by running CMD, then exiting, to wake both PC's since I had previously set that up in the Scheduler. 



#12 lti

lti
  • Topic Starter

  • Members
  • 592 posts
  • ONLINE
  •  
  • Local time:09:50 PM

Posted 31 December 2013 - 11:25 PM

Keep in mind, that it can take 10 to 20 minutes, before the computer may go to sleep.  Look on Support.toshiba.com for a older AHCI or ACPI driver for your machine.

 

I never place any of our machines in sleep mode, unless it is on battery power.  Otherwise, it is complete shut down.  We started seeing this issue, when Windows XP SP3 rolled out, regarding machines no longer going into Sleep mode.  That issue stuck around with Windows 7 SP1 and is still there with Windows 8.x.

This computer does automatically go to sleep after 15 minutes when running on battery. The problem is that it was waking up shortly after going to sleep and draining the battery. That happened using every method to put it to sleep. It stayed asleep yesterday, and I don't know why. It is set to never go to sleep automatically when plugged in.

 

Most newer machines, will allow you to set in the bios, to wake up on a "Magic Packet", for scheduled tasks.

I saw that setting when I was looking at the Ethernet controller properties in Device Manager. It is disabled there, but I don't know if the BIOS has that setting. I haven't even looked at the BIOS on this computer, but the Toshiba program that allows me to change BIOS settings from within Windows says that Wake on LAN is disabled. I'm not using Ethernet, and the wireless network controller has all power management settings disabled and grayed out in Device Manager.



#13 lti

lti
  • Topic Starter

  • Members
  • 592 posts
  • ONLINE
  •  
  • Local time:09:50 PM

Posted 05 January 2014 - 12:35 PM

It won't go to sleep now. I guess this only happens on Sunday. The audio hardware is waking the computer, but there is no audio playing. Changing the driver version or using the generic Microsoft driver does not help. It has some really lousy Conexant SmartAudio device.

Attached Files


Edited by lti, 05 January 2014 - 12:39 PM.


#14 lti

lti
  • Topic Starter

  • Members
  • 592 posts
  • ONLINE
  •  
  • Local time:09:50 PM

Posted 12 January 2014 - 07:57 PM

It looks like it will not go to sleep if it runs on battery for any length of time. It still won't go to sleep after I plug it back in to charge the battery. I didn't notice because it stays plugged in most of the time. If I want it to go to sleep, I have to shut down, plug it in, and turn it back on. After that, sleep works until I unplug it again.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users