Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Corsair Raptor M30 unresponsive


  • Please log in to reply
1 reply to this topic

#1 coolyellow42

coolyellow42

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:08:57 AM

Posted 22 December 2013 - 07:43 AM

Hi all,

 

A while ago I purchased a Corsair Raptor M30 mouse (after reading generally positive reviews) but it is only now I have decided to use it. I am using a Dell XPS 8300 with two USB ports at the front of the computer tower and 4 (or 3?) at the back. Around the back I have the keyboard and monitor plugged in (I think..) as well as the printer, which I recently disconnected.

 

However, when I plug my Corsair mouse in the back it does not work. I know this is not a drivers thing as I remember installing those, and the mouse did work perfectly for a day before the problem started. The red light at the back of the mouse will be on (and the red laser pointer at the bottom) but moving the mouse will not move the cursor, and when I try to change the sensitivity of the mouse using the button behind the wheel, this will not work. Occasionally my keyboard will stop working as well (it is a generic keyboard I received from Dell upon purchasing the computer). The lights will come on indicating Caps Lock etc but typing will produce nothing. Plugging it in using the front USB ports has a similar result. It will instantly cause both of the ports to stop working, (one being my wireless adapter, the other the mouse).

 

I have another mouse (again something that came with the computer) but the left click on this mouse is almost broken. However, it does not cause any of these problems when plugged in at the back (I have not tried around the front).

 

I am completely useless with hardware and computer components (so please don't ask me to take it apart :smash: !) but I am guessing that this is a fault of the mouse. I am also averse to buying a new one as the will mean the £20 i spent will be down the drain and the new one may just cause a similar problem.

 

Can someone diagnose this problem and suggest a fix, or (if there isn't one) recommend an inexpensive mouse that is good to use but will not cause this problem.

 

Thanks for reading this  :thumbup2:


Edited by coolyellow42, 22 December 2013 - 03:27 PM.


BC AdBot (Login to Remove)

 


#2 goldfist

goldfist

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Hampshire, USA
  • Local time:02:57 AM

Posted 28 December 2013 - 07:24 PM

Have you tried this mouse on another computer to see if the mouse actually works? Since this is a corded mouse it shoudl work as plug-n-play and be up and running quickly. If plugged into another computer it doesnt work, then I'd say the mouse is bad and should be returned via warranty replacement hopefully.

 

Found this mouse at newegg for $50 USD and surprised the price tag. I'd only spend that much if it was cordless and rechargeable like the Logitech I had. http://www.newegg.com/Product/Product.aspx?Item=N82E16826816021


Edited by goldfist, 28 December 2013 - 07:28 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users