Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problems with Vine videos in Firefox 26.0


  • Please log in to reply
1 reply to this topic

#1 Angel Rodriquez

Angel Rodriquez

  • Members
  • 76 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:59 AM

Posted 21 December 2013 - 03:42 AM

I have the latest version of Firefox (26.0). I'm not sure if a Flash or Java update caused this issue.
 

Vine videos were playing fine in my browser. This was AFTER I changed the about:config settings for media.windows-media-foundation.enabled to "false" - They never seemed to load when this was set to "true"

This was based on the tutorial I found here:
https://support.mozilla.org/en-US/kb/vine-and-other-html5-videos-wont-play?esab=a&as=aaq
 

But now, the problem is back. Vine videos will not play. I recently updated to Firefox 26.0 and this issue came back. Additionally, I did install a Java update. I'm not sure what caused the issue, honestly.  It might even be Flash.

I have tried EVERYTHING to restore my browser to the way it was but nothing works. I have reinstalled Firefox. I have done clean installs of both Flash and Java. I have tried starting Firefox in safe mode, but the problem remains.
 

If I go to a Vine page (https://vine.co/v/heXdnb0m3dm) for example, all I see is a static image. I can't click on anything. It's just a static frozen image. On Twitter, the same Vine video appears as a black screen where it previously used to load just fine. Even on Tweetdeck, which uses Firefox as the default browser, the videos will no longer load. This is all when media.windows-media-foundation.enabled is set to "false"

I thought it might be an issue with Flash, but other Flash videos load fine.  I've done tests to ensure that both Java AND Flash are installed on my browser.  This is what the image looks like when media.windows-media-foundation.enabled is set to "false" on Firefox:

FirefoxVine.jpg

Notice, there is no profile info showing.  The "sharing" icons aren't featured on the left hand side.  Nothing.  Just a static image.

 

If I change the settings so media.windows-media-foundation.enabled is set back to "true" then the video plays but I have no control over sound. There is, in fact, no sound. The video plays on a loop. No sound. In fact, I can not even control the sound icon. Clicking the icon does nothing. It doesn't change to signify that the sound is on or muted. It remains the same muted icon.  The same features are lacking (share, profile info, etc).  The ONLY difference is that the video plays but without sound.

 

So, basically if I try to play Vines by forcing them into flash, I get nothing at all. I get a static image. No video. No sound. No function.

If I leave the defaults the same and play them via HTML5, the video plays, but there is no sound and no control.

Now see the difference playing them in IE:

IEVine.jpg

Notice the sharing options on the left.  Notice that the user profile info and video info is posted on the right.  Notice that if I right-click I have additional controls over the video.

Those same features are also present in Chrome:

ChromeVine.jpg
 

Please help! I have tried everything at this point!

 

 



BC AdBot (Login to Remove)

 


#2 Angel Rodriquez

Angel Rodriquez
  • Topic Starter

  • Members
  • 76 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:59 AM

Posted 21 December 2013 - 07:10 AM

UPDATE: I temporarily went to "about:config" on Firefox

I set the "security.csp.enable" to "false" and the pages load up perfectly.


Is this safe, though? Should this feature be enabled for a reason?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users