Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dell Inspiron 1100 - Linux GPU Driver Issue


  • Please log in to reply
2 replies to this topic

#1 goldfist

goldfist

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Hampshire, USA
  • Local time:01:46 AM

Posted 20 December 2013 - 07:05 PM

So I have this 10 year old laptop that I was going to run Mint 15 XFCE on which is a Dell Inspiron 1100 with a Celeron 2.4Ghz CPU, 768MB RAM, and 20GB IDE HDD.

 

Problem I have is that while the install is flawless of MINT 15 XFCE to the HDD, upon reboot I get the POST of the laptop and then when Linux MINT 15 boots the screen goes black and nothing displayed.

 

Prior to attempting to install Linux on this laptop it was running Windows XP Home SP3 with no problems. So the hardware is good.

 

So I am trying to figure out why the driver seems to go out to lunch for this install.

 

Here are the distros I have tried with same results

 

Linux MINT 15 XFCE 32-bit        - Black Screen After install

Linux MINT 15 KDE 32-bit          - Black Screen After install

Linux MINT 15 Cinnamon 32-bit - Black Screen After install

Linux MINT 14 Cinnamon 32-bit - Black Screen After install

Linux MINT 13  32-bit                 - Black Screen After install

 

To rule out Hard Drive corruption, I swapped the 20GB IDE HDD with a known good 12GB IDE HDD and got same results with Linux MINT 15 XFCE

 

To rule out a memory issue of any kind, I performed Memtest86 off of an old Knoppix 4.0.2 CD I had and also out of curiosity I decided to boot this laptop off of Knoppix 4.0.2 and it worked fine, but slow off of the Live CD distro with no graphics issues.

 

** So question i have is... obviously the driver Linux is using during the install of MINT 15 works flawless, is there a way to specify for this system to continue to use that GPU Driver instead of whatever it may be failing to correctly detect as a matching driver for the video?

 

I looked around for a way to manually specify what driver to use, and Knoppix 4.0.2 is great because on boot it shows in plain colored text what it detected for hardware and you then have an idea of what GPU driver to use, but without the ability to get MINT 15 to boot with an operational display I simply just see HDD activity and black screen and its useless to troubleshoot further without attempting to go backwards with distros burning DVD after DVD until I might find one that works, but figured I'd seek professional help on this from some Linux guru's who have seen this before downloading obsolete MINT distros and settling for say MINT 5 etc which is no longer supported for security updates etc.

 



BC AdBot (Login to Remove)

 


#2 jonuk76

jonuk76

  • Members
  • 2,168 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wales, UK
  • Local time:07:46 AM

Posted 21 December 2013 - 07:21 AM

So these work fine from a live CD and are totally usable , but once installed fail to load properly, correct?

 

Do you see the GRUB menu (the boot menu straight after POST where you choose which OS to load).  If no GRUB menu is displayed, try  holding down shift just after your system is powered up as per here.  From the GRUB menu you should be able to enter recovery mode.  One of the options in the recovery menu is "Run in failsafe graphic mode" which will be worth a try.  Recovery mode is also verbose (outputs text describing each step of the loading process) so if it is hanging on a particular step, it will be helpful to note what that is.

 

I can say that in one old system I had, I would always have boot problems with Linux unless ACPI was disabled.  Is there an option to do this in the system BIOS?  I also recall I had to do something during install to disable ACPI but it's been a long time and I can't remember exactly how I did it, or whether it would apply to current distributions, sorry :(  EDIT - did a bit of googling and found this - http://askubuntu.com/questions/160036/how-do-i-disable-acpi-when-booting which looks like what I had to do before.

 

Finally, I would also suggest registering with the Linux Mint forums and Ubuntu forums (Ubuntu forums are busier, and Mint is based on Ubuntu so they may also be able to help) and seeing if anyone there has suggestions - there are some really knowledgeable people out there.


Edited by jonuk76, 21 December 2013 - 07:27 AM.

7sbvuf-6.png


#3 goldfist

goldfist
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Hampshire, USA
  • Local time:01:46 AM

Posted 21 December 2013 - 05:43 PM

Thanks for the info... I will give this a shot when I get home from work and will report back.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users