Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Broken MBR?


  • Please log in to reply
1 reply to this topic

#1 breebreebran31

breebreebran31

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:20 AM

Posted 15 December 2013 - 03:07 AM

I had linux installed alongside Windows 8.
But I got tired of it so I deleted it with gparted.
But now theres no boot record.
So I popped in a windows repair disc.
First I tried doing automatic repair.
It didnt work.,
Then I went on command prompt.
I did bootrec /fixmbr

bootrec /fixboot

bootrec /rebuildbcd

 

fixmbr and fixboot said operation successful.
But I rebooted and still had no boot loader.
So I went back to cmd.
Then I did bootrec /rebuildbcd

It said "Windows installations: 0
Operation complete"
I have windows 7 on one hdd and windows 8 on another.
I don't know why it's telling me theres no installations.
So I did sfc /scannow on the windows 8 hdd. It claimed to repair windows 8 but some files couldn't be repaired.
But when I choose to boot from the windows 8 hard drive then it lets me boot into windows. Still no boot menu though. 
But I need to fix the mbr.
So I went back into cmd on the recovery disk and did diskpart and list volume.

It shows all my hard drives. D:\ which is windows 8
But then it shows C:\ but doesn't say windows 7 is installed on it.
Which is wrong because I can go on windows 8 and see everything on the windows 7 hdd.
Any help?



BC AdBot (Login to Remove)

 


#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:11:20 PM

Posted 15 December 2013 - 03:32 AM

bios settings UEFI stuff is confusing (bleeping us up) all of us.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users