Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

New Build Gaming System! Need Help ASAP!!!


  • Please log in to reply
1 reply to this topic

#1 hbeaufelipe16

hbeaufelipe16

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:23 AM

Posted 30 November 2013 - 07:55 PM

I need some help regarding issues on my newly build system. Everything is set up fine but for the first boot up, NO POST/NO BEEPS and NO DISPLAY. I tried to try to fix it on my own but still no good response so I decided to post here, maybe someone can help me with my issue

Here are the SPECS on my SYSTEM:

CPU - AMD FX 4-Core Black Edition FX-4300 (FD4300WMHKBOX)

 

MoBo - ASRock 970 Extreme3 r2.0

 

GPU - MSI Radeon R9 270X GAMING 2GB GDDR5 (R9 270X GAMING 2G)
- 1030 MHz Clock, 5600 MHz Memory
- PCI-Express 3.0, DVI, HDMI
 
RAM - G.SKILL Trident X Series 8GB (2x4GB) DDR3 2400MHz CL10 Dual Channel Kit (F3-2400C10D-8GTX)

 

HDD - WD 1Tb Caviar Blue

 

PSU - Corsair CX600M

 

Cooling - Corsair H55 Liquid Cooling

 

Case - NZXT Phantom 410 WHITE Crafted Mid Tower Case
 



BC AdBot (Login to Remove)

 


#2 DJBPace07

DJBPace07

  • BC Advisor
  • 4,869 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:23 AM

Posted 03 December 2013 - 07:18 AM

Do you have another GPU you can try?  Did you make sure all power cables to the motherboard and GPU are connected?  Is the motherboard seated properly?


3939.png

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users