Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

external hard drive


  • Please log in to reply
7 replies to this topic

#1 SHANT1969

SHANT1969

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 21 November 2013 - 04:52 PM

I have a Toshiba v63600-A 500GB external hard drive. In device manager, it states that it is working properly but 'My Computer' is not detecting it for use. I am using a Toshiba Satellite laptop running Windows 8. Please help me.


Edited by SHANT1969, 21 November 2013 - 04:53 PM.


BC AdBot (Login to Remove)

 


#2 Greg62702

Greg62702

  • Banned
  • 717 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:51 PM

Posted 21 November 2013 - 11:12 PM

How long have you had this hard drive unit?  It is no longer manufactured by Toshiba.  Does it work on another computer, when you attach it?  It may be that hard drive unit has finally died.

 

The Canvio line took the place of that antique btw.  If it is not being seen when you connect to any computer, sorry to say, but the unit is most likely no longer functioning.



#3 SHANT1969

SHANT1969
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 22 November 2013 - 01:34 PM

I actually got the drive recently. The specs started the it would work with Windows 8. I've not tried it with another computer yet.

#4 Bad Caps

Bad Caps

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Mission, BC
  • Local time:11:51 AM

Posted 22 November 2013 - 02:22 PM

Does the drive show in Disk Management? It may need to be initialized.



#5 SHANT1969

SHANT1969
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 22 November 2013 - 02:32 PM

Yes. But I am unable to do anything with it. Formatting, renaming etc.

#6 Greg62702

Greg62702

  • Banned
  • 717 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:51 PM

Posted 22 November 2013 - 03:06 PM

I actually got the drive recently. The specs started the it would work with Windows 8. I've not tried it with another computer yet.

Where did you get the spec's from, and where did you purchase the drive from?  Like I stated before, that unit is no longer manufactured.



#7 SHANT1969

SHANT1969
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:51 PM

Posted 22 November 2013 - 03:21 PM

http://www.toshiba.com/us/accessories/Storage/Desktop-and-Portable-Hard-Drives/500GB/HDTC605XW3A1

#8 Greg62702

Greg62702

  • Banned
  • 717 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:51 PM

Posted 22 November 2013 - 06:24 PM

So which is it that you have?  The one you just posted the link for, or the model# you are asking about?  Those are two different models.  As I already stated, have you tried plugging it into another computer, to see if that computer sees the drive?  Have you contacted Toshiba regarding getting a new cord for it, or sending your unit in to be looked at, to see if it is DOA.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users