Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Audio sucking up free CPU resources


  • Please log in to reply
2 replies to this topic

#1 Dragongirl

Dragongirl

  • Members
  • 207 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Harbin, China
  • Local time:11:46 AM

Posted 14 November 2013 - 10:29 PM

Not sure if this should be in hardware or software, mods, you may move it if needed

 

System: Dell Laditude D620 Business Laptop {Reformatted drive with Windows XP Professional over Vista Business}

Hard drive: 80GB

RAM: 2GB {doubled from 1GB one month ago as of this post}

 

Trouble: Windows Audio service hogging up the CPU resources that are not in use.

 

OK, here's my trouble.

 

I recently replaced my 1GB ram with a brand new set of two 1GB sticks doubling the ram in this laptop. exactly 24 hours ago {as of this post} One svchost began overloading my CPU up to 50% used when everything else is using very little of it. Normally I;d think nothing of it and not care, but I keep my Windows Task Manager near my clock at all times incase I need to kill a proccess in a heartbeat or less.

 

So naturally I kill that proccess when CPU use got to around 55% or more for that single proccess. Then my audio shut down. So I restarted it, Once more that same svchost is sucking up CPU reserves up to around 55-60% in use. with 2GB ram this is not too much of a problem, but I am used to having my CPU running at barely 8-12% even with ten tabs open in Google Chrome.

 

Seeking advice of what to do at this time of how to fix this really quick. I thought restarting might do it, but I am currently scanning with MBAM at this time.

 

Its nothing too major, it is just starting to worry me.


Edited by Dragongirl, 14 November 2013 - 10:30 PM.

The kitten that used to be linked to here in this signature now has her forever home!! Thank you for taking the time to read this signature!

 

"This is the coolest place I've ever been, and I've only been alive for three days!" ~ Figment


BC AdBot (Login to Remove)

 


#2 SpywareDoc

SpywareDoc

  • Members
  • 676 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Maryland, USA
  • Local time:11:46 PM

Posted 16 November 2013 - 10:46 AM

Question: Why buy more 'resources' if you're just going to get upset when the computer tries to use them? ;)



#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,127 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:46 PM

Posted 19 November 2013 - 03:50 PM

I think OP is talking about apples (CPU) and oranges (RAM).

 

CPU usage on a system as reflected by Task Manager...will vary according to the program and what it's doing ,  When I edit video, my CPU usage for that editor climbs to 50-60% or so per Task Manager...while rendering edited video.  To my knowledge, that's the only program I have installed which does that...and I understand that it's because rendering video is a CPU-arduous task. 

 

I don't even pay attention to memory usage in Task Manager...there's no point because I have 8GB installed...plus a pagefile...and even if XP only handles 4GB, that's more than enough for anything that I do.

 

Think about this...System Idle process in Task Manager is a way of telling you "this much of your CPU is not doing anything because it doesn't have to."  System idle process numbers will probably never be zero or near-zero, IMO, unless something truly unusual is going on with your system.  I've never seen Windows give any warning re low or high CPU-usage...the warnings, if they come, all have to do with "insufficient resources" (not enough RAM) or something related to RAM/memory.

 

If you are concerned about servicehost processes...you can explore those by using tools like Process Explorer Mini-guide and Screenshots - http://www.bleepingcomputer.com/forums/topic354690.html and Process Explorer - http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx .

 

What is svchost.exe And Why Is It Running the How-To Geek - http://www.howtogeek.com/howto/windows-vista/what-is-svchostexe-and-why-is-it-running/

 

What is the Host Process for Windows Services The Mysterious Svchost.exe Windows Host Process - http://www.brighthub.com/computing/windows-platform/articles/45450.aspx

 

Until a system has a problem...I see no need to monitor anything going on in Task Manager, unless it's strictly idle curiosity.  Idle curiosity is the only reason I ever looked at CPU-usage when rendering and I didn't bother to note the RAM-usage.

 

Louis


Edited by hamluis, 19 November 2013 - 03:51 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users