Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External Drive - Parted Magic Check Fat


  • Please log in to reply
2 replies to this topic

#1 doggyofone

doggyofone

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:12:45 AM

Posted 08 November 2013 - 08:32 PM

I've been going through James' tutorial for repairing an external drive with the raw data problem. The deep scan came up with the following:

The drive scan shows it to be NTFS. Then the deep scan showed the following message:

 

Check Fat: can't read fat boot sector

Invalid fat boot sector

0 D Fat 16 <32M 250453 131 50 252628 235 40 34947918

 

This message repeats several times with differences in the string of numbers after 32M

 

I'm not sure what this means, but this is not shown in the tutorial.

 

Is there a solution to be found somewhere within the forum?

Windows 7 Ultimate

IOMEGA 1.5 gig external hard drive

Parted Magic Linux Kernel 3.5.6

 

Thanks


Edited by doggyofone, 08 November 2013 - 08:35 PM.


BC AdBot (Login to Remove)

 


#2 Anshad Edavana

Anshad Edavana

  • Members
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:11:15 AM

Posted 09 November 2013 - 01:38 PM

Hi

 

I guess you are using "TestDisk" to fix the RAW partition. Please give a try to repairing corrupted volumes using "Gparted" which came with Parted magic. I had great success with it in similar situations.

 

 

http://aztcs.org/meeting_notes/winhardsig/harddrives/repairing/050-HDdatarecovery.pdf



#3 doggyofone

doggyofone
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:12:45 AM

Posted 09 November 2013 - 05:05 PM

Thanks for the help. Solved a different way:

I did go through the procedure through step 13, but no success. As I ran the repair I received the following:

 

>calibrate /dev/sbd1

>ntfs resize - P - i - F - V/dev/sdb1

device name :/dev/sdb1

ntfs volume version 3.1

cluster size : 4096 bytes

Current Volume Size : 1500299264512 bytes (1500300 mb)

Current device size : 150299265024 bytes (1500300 mb)

checking for bad sectors

ntfs_attr_pread_ic ntfs_pread failed : input output error

checking file system consitency...

Accounting clusters

Error (S) Couldn't get $Bitmap $dada : input/output error

 

I Google searched the input/output error by exact wording and came across a bunch of Linux notes. Finally the consitent theme was do this or do that and then run chkdsk /f in via cmd in Windows.

 

Did it and voila - fixed. Way too simple.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users