Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Update setting keep being greyed out


  • Please log in to reply
4 replies to this topic

#1 David11

David11

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:09:40 AM

Posted 04 November 2013 - 05:05 AM

(I'm using Vista Home Premium)

 

I've noticed for a while that the setting keeps being changed from "Install updates automatically (recommended)" to "Check for updates but let me choose whether to download and install them".

 

At the same time, the "Restricted Sites" section of Spyware Blaster becomes "Partially enabled", although everything there seems to become unticked.

 

To fix the Windows Update issue, I go into regedit and delete the key HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU\AuOptions

 

This keeps being created with the value of 2.

 

I've noticed recently that a definition update for Windows Defender has occurred shortly before I've noticed this has happened again.  But this may just be a coincidence.  The WD service is disabled, I have KIS.

 

If anyone has any suggestions on what is causing this or, alternatively, ways in which I can track what is making these changes, that would be great.

 

I don't think it's malware, but who knows?


Edited by David11, 04 November 2013 - 05:11 AM.


BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,363 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:01:40 AM

Posted 13 November 2013 - 01:03 PM

Unless you know exactly what you are doing when editing the registry I would suggest leaving it alone.  One mistake can render your computer inoperable.

 

Try running the Fix it at Microsoft Support.  You will need to scroll down the page to find it.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 David11

David11
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:09:40 AM

Posted 14 November 2013 - 04:24 AM

Unless you know exactly what you are doing when editing the registry I would suggest leaving it alone.  One mistake can render your computer inoperable.

 

Try running the Fix it at Microsoft Support.  You will need to scroll down the page to find it.

 

Thanks for replying, but, no, that support page is of no use, unfortunately.

The issue is that something keeps adding the policy key and I don't know what it is.



#4 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:08:40 AM

Posted 14 November 2013 - 06:23 AM

Thats part of local computer policies and you cannot edit that in the registry. You will need to load up gpedit.msc to edit that particular policy for the local machine. It is being generated by Group Policy Objects. Some versions of Windows do not have gpedit.msc.

So if you have any other version of Windows Vista that is not Ultimate you will not have gpedit.msc available to edit this policy. You will want to disable Windows update from the Automatic Updates section.

#5 David11

David11
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:09:40 AM

Posted 14 November 2013 - 08:37 AM

Thats part of local computer policies and you cannot edit that in the registry. You will need to load up gpedit.msc to edit that particular policy for the local machine. It is being generated by Group Policy Objects. Some versions of Windows do not have gpedit.msc.

So if you have any other version of Windows Vista that is not Ultimate you will not have gpedit.msc available to edit this policy. You will want to disable Windows update from the Automatic Updates section.

 

Thanks. Which I guess begs the question as to why a stand-alone computer that has never been attached to a managed network has a group policy.  Especially when there isn't even a tool on the computer to edit it!

 

However, this gave me a bit more to work with and I found this article on how to reset local security policy to the defaults.  So, I guess I'll have to wait and see whether the AUOptions key appears again in the future.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users