Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Many dllhost.exe processes running


  • Please log in to reply
3 replies to this topic

#1 Peco

Peco

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:50 PM

Posted 01 November 2013 - 09:23 AM

Hi,

 

I'm having trouble with a Windows 7 PC.  There are multiple instances of dllhost.exe running, 19 as of now.  They all come from Windows/System32, and a few of them are hogging a lot of memory. The description on all of them is COM Surrogate. I'm not really sure where to go from here, as I would rather not reinstall Windows.  If I try to kill one of the processes, another will pop up.  I haven't ruled out malware as being the problem, even though I have ran many scanners including MBAM.  and rootkit scanners.  These processes are literally taking up over 50% of my system memory.

 

Randomly, the system (upon boot sometimes) will tell me that COM Surrogate has failed, or something to that nature.  Another, apparently random thing that pops up is a small Internet Explorer window that asks me if I'm sure I'd like to leave this page.  Even if I'm not browsing.  Both of these can pop up immediately after boot, but not routinely.

 

Any thoughts?


Edited by hamluis, 01 November 2013 - 04:51 PM.
Moved from Win 7 to Am I Infected - Hamluis.


BC AdBot (Login to Remove)

 


#2 Roodo

Roodo

  • Members
  • 760 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:50 PM

Posted 01 November 2013 - 01:09 PM

Try
http://support.kaspersky.com/viruses/rescuedisk
Run from bootup

#3 Peco

Peco
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:50 PM

Posted 04 November 2013 - 09:51 AM

I used the rescue disk virus scan and updated defintions to the latest, to check boot sectors and hidden startup objects (the defaults).  Found nothing.  Now I'm scanning everything (all of the windows partions, recovery partion, etc.)

 

I left the PC on overnight and this morning when it woke it up, so to speak, it had a dozen or so "COM Surrogate has stopped working", along with 3 IE popups.  This was of course before I started the Kaspersky rescue disk.  Just throwing out some symptoms.

 

Any help would be appreciated.

 

Thanks.


Edited by Peco, 04 November 2013 - 11:37 AM.


#4 Peco

Peco
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:11:50 PM

Posted 04 November 2013 - 11:35 AM

Kaspersky Rescue Disk found "HEUR:Exploit.Java.Generic" and I deleted it.  Started up computer again, solved!  Thank you!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users