Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB ports not working


  • Please log in to reply
4 replies to this topic

#1 hockeymidget8

hockeymidget8

  • Members
  • 97 posts
  • OFFLINE
  •  
  • Local time:11:09 PM

Posted 29 October 2013 - 03:32 PM

Hello. I'm having trouble with the USB ports on my computer.

 

When my mouse was plugged in, the laser light came on, but it didn't move the cursor. I tried plugging it into the other usb ports on my computer, but to no avail. Thinking it was the mouse that was the problem, I then found a brand new mouse in my basement, unopened from its package, and tried to use it. When I plugged it in the light on the bottom of the mouse came on similar to the last mouse, and windows began installing drivers for the new device. When it was done with that however, the cursor would still not move. I tried all of the USB ports again and had the same problem.

 

I then tried to plug in an external hard drive. Similarly to the mice, when I plugged it in I could hear the inner workings of the hard drive whirring and buzzing, so it was receiving power, but the hard drive was not there in Explorer.

 

I have a Toshiba Satellite L505 es5018. I am running Windows 7 Home Premium.

 

Thanks for your help.



BC AdBot (Login to Remove)

 


#2 hockeymidget8

hockeymidget8
  • Topic Starter

  • Members
  • 97 posts
  • OFFLINE
  •  
  • Local time:11:09 PM

Posted 29 October 2013 - 03:39 PM

Also of note: Device manager doesn't show any erros (yellow exclamation marks) or any obvious indicators that something is wrong/missing.



#3 sandman1374

sandman1374

  • Members
  • 65 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Grand Rapids Michigan
  • Local time:11:09 PM

Posted 29 October 2013 - 05:54 PM

I only have a couple suggestion that may or may not help.

 

I would also try a known working thumb drive if you haven't already. Reason I say this is I also occasionally use my external drive on four other machines in my home and it works great but when said external is connected to my main rig (listed in sig) it acts just as you described and fails to function, but if I connect the drives second USB connection (cord is a "Y" type) it functions just fine. I don't trust it lol. If you haven't already, try something else known to work.

 

If system still has issue (guessing it will) you might try uninstalling USB drivers (download latest version first) and then reinstall.

 

I have to guess this machine is a couple years old?

Has it been a while since it's been re-imaged?

Maybe never?

 

If this is the case maybe as a last resort try restoring factory default settings (factory image located on HDD). This will erase all current data (doc, pics etc) so be sure to make a backup of EVERYTHING you want/need.

 

This is how it's done,

 

Run on AC w/battery,

Hold zero key (above O+P keys),

Turn on pc and hold zero till pc loads and is beeping than release.

Choose first selection + click next till windows is loading files takes roughly an hour or so to complete.

 

At this point you'll need to reinstall all programs you use such as antivirus, browser etc.


Custom, AMD R7 1800x @ 3925MHz. ASUS Crosshair VI Hero, 2 x 8GB G-Skill Flare-X @ 3466MHz 14-13-13-26-1T, Samsung 960 m.2 NVMe OS. Samsung 840 Pro 120GB SSD OC OS. 2TB WD Blck data, 4TB WD Red Storage, EVGA G2 850 PSU, HD7970 3GB w/XSPC Razor WB. EK C6H Monoblock,  D5 Vario, RX360 rad,RS360 rad, EX140 rad, Xigmatek Elysium. Win10 Pro x64, Linksys WRT1900 ACS, Firefox Beta, Avast Free, Malwarebytes Pro, CCleaner,


#4 RobinHoodSnr

RobinHoodSnr

  • Members
  • 158 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Africa
  • Local time:05:09 AM

Posted 30 October 2013 - 10:07 AM

Go to your bios and see if USB ports are set to LEGACY or not. Sometimes, changing these setting DOES help...


...We all know something...but we will NEVER know everything :grinner:

 

Cryptlocker "Process" remover...will NOT delete Cryptolocker, only the processes...( a "safety precaution" I took for those who still want to "try" paying the ransom to get their files back. DON'T FORGET TO MONITOR YOUR TIME LEFT BEFORE PAYMENT! )

 

("KillCrypt" will automaticly open %appdatadir%...just guide this to Cryptolocker-Virus and double-click on it. Remember...if you "restart" your system, the processes will be back...use this only for emergencies if you want to create a quick document. While this processes is killed, your docs wont get infected, but WILL be encrypted (unusable) when you restart the PC/Laptop OR clicking on the Virus again!!!)


#5 slgrieb

slgrieb

  • Members
  • 270 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas Panhandle
  • Local time:09:09 PM

Posted 30 October 2013 - 06:54 PM

Any time you experience an apparent hardware error, a good place to start is by taking Windows out of the picture. Boot up the machine in the Linux distribution of your choice Mint, Puppy, or whatever. If the device works OK in Linux, you either have a problem with a Windows device driver, active malware, or a damaged Windows installation.


Edited by slgrieb, 30 October 2013 - 06:57 PM.

Yes, Mr. Death... I'll play you a game! But not CHESS !!! BAH... FOOEY! My game is... 
WIFFLEBALL!

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users