Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Mac Rogue remover.app is damaged and can't be opened


  • Please log in to reply
9 replies to this topic

#1 Genex17

Genex17

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 26 October 2013 - 04:09 PM

I have downloaded and tried to run the mac-rogue-remover.app on my Macbook running OSX 10.9 and I get this message:

 

"Mac Rogue remover.app is damaged and can't be opened. You should move it to the Trash."

 

Download page: http://www.bleepingcomputer.com/download/mac-rogue-remover-tool/dl/22/

 

I extracted it to the Desktop. Is it Mavericks or something else causing this?

 

Gene

 

 



BC AdBot (Login to Remove)

 


#2 Eric.Lee

Eric.Lee

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:39 AM

Posted 30 October 2013 - 02:22 AM

Hey Gene,

I'm running Mavericks and the app runs fine for me. Have you tried re-downloading it? Has a rogue infected your Mac?

Here is a support-topic for the app, but I don't know whether that thread is still valid: http://www.bleepingcomputer.com/forums/topic399803.html

Eric

Edited by Eric.Lee, 30 October 2013 - 02:23 AM.


#3 Genex17

Genex17
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 30 October 2013 - 07:50 AM

Thanks for the reality check. I saw no Mac rogueware in CPU processes or in Startup items.  I found the problem,but it is odd.

 

I went into System Preferences > Security and set "Allow Apps downloaded from anywhere." (Ctrl + click Open did not work) and tried opening it again.

 

Then I got the warning it was from the Internet and if I wanted to open it.

 

After that it ran normally and reported no rogue ware and runs fine after that. If I extract a fresh copy, I get the same problem and have to turn off Gatekeeper.

to get it running. (Gatekeeper is back on) I don't know why I got the "damaged app" error.

 

That had me going for a bit.

 

Gene



#4 LilBambi

LilBambi

  • Members
  • 126 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:39 AM

Posted 30 October 2013 - 02:18 PM

I have found that default limitation is a real pain. Most Mac users have no idea what is wrong when they can't run something in Lion, Mountain Lion or Mavericks. Hey don't know they have to change that setting.

 

I wish Apple would have a fourth item in the list. Mac users shouldn't have to allow everything just to run a utility to -- for instance share a USB printer or scanner, etc. with another computer.

 

I personally think they should have a fourth item that allows you to add a developer/program to the list. The user still has to make a definite decision to do that, but it's not Apple, Apple and approved developers or EVERYTHING.  :thumbup2:


Bambi
AKA Fran
My Public Key for Email :: BambisMusings Blog
"The Net interprets censorship as damage and routes around it." ~John Gilmore (Time Magazine, Dec 6, 1993)


#5 Genex17

Genex17
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 30 October 2013 - 06:48 PM

There usually is a shortcut that over rides the gatekeeper Ctrl + click on the icon,then select Open from the menu. Saves from having to open system preferences.

 

What caught me off guard was the "application damaged message."



#6 LilBambi

LilBambi

  • Members
  • 126 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:39 AM

Posted 30 October 2013 - 07:10 PM

There usually is a shortcut that over rides the gatekeeper Ctrl + click on the icon,then select Open from the menu. Saves from having to open system preferences.

 

What caught me off guard was the "application damaged message."

 

Awesome - Thanks Genex17!

 

I didn't know that! That is great news. So let me make sure I understood you correctly. You can override the gatekeeper with a CTRL+Click to over ride on a one off basis? Or is that just a shortcut to get to the Security preferences to make the change to allow everything?


Bambi
AKA Fran
My Public Key for Email :: BambisMusings Blog
"The Net interprets censorship as damage and routes around it." ~John Gilmore (Time Magazine, Dec 6, 1993)


#7 Genex17

Genex17
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 30 October 2013 - 09:58 PM


Awesome - Thanks Genex17!

 

I didn't know that! That is great news. So let me make sure I understood you correctly. You can override the gatekeeper with a CTRL+Click to over ride on a one off basis? Or is that just a shortcut to get to the Security preferences to make the change to allow everything?

 

 

The shortcut overrides the Gatekeeper by allowing you to open the unsigned app, be very sure you trust that app.

 

Here's a good reference: http://www.bu.edu/infosec/howtos/bypass-gatekeeper-safely/



#8 LilBambi

LilBambi

  • Members
  • 126 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:39 AM

Posted 31 October 2013 - 08:40 AM

Thanks for the clarification. It is just what I was hoping for!  :bananas:


Bambi
AKA Fran
My Public Key for Email :: BambisMusings Blog
"The Net interprets censorship as damage and routes around it." ~John Gilmore (Time Magazine, Dec 6, 1993)


#9 Genex17

Genex17
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 31 October 2013 - 06:35 PM

Great! solved my issue and helped out someone else. :thumbup2:

 

Now just need to get over my cold  :thumbdown:

 

Gene



#10 LilBambi

LilBambi

  • Members
  • 126 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:39 AM

Posted 31 October 2013 - 07:59 PM

So many having colds ... hope you get well soon! :cold:

 

And thanks Gene!  :cool:


Bambi
AKA Fran
My Public Key for Email :: BambisMusings Blog
"The Net interprets censorship as damage and routes around it." ~John Gilmore (Time Magazine, Dec 6, 1993)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users