Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Disk Rescue Error Parted Magic - ddrescue : write error no space left on device


  • Please log in to reply
1 reply to this topic

#1 burgers

burgers

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:52 AM

Posted 15 October 2013 - 10:46 AM

Hi,

 

I've been following a guide on one of your posts about using parted magic to recover files and clone the damaged internal drive from my vista pc, and have managed to resuce all the accessible files using Parted Magic, but am now having trouble with the ddrescue procedure.

 

I have followed the post and linked guides by James Litten, whome I'm extremely grateful to for this and his other relevant posts linking from them..)

 

http://www.bleepingcomputer.com/forums/t/446058/windows-xp-repair-doesnt-show-already-installed-os-drive-seems-formatted-anxious-about-data/

 

and when I type in my line in the LX terminal which goes something like this

 

ddrescue -r 3 /dev/sda1 /media/sdb1/image.dd /media/sdb1/rescuelog.log (replacing the appropriate /dev/sdaa1 & /media/sdb1 with my damaged source and destination drives, everything proceeds well for a few minutes and then i receive an error code

 

ddrescue : write error no space left on device

 

Now, Ive tried this with a number of destination drives all much larger than the damaged source and get the same error so I'm sure I'm doing something wrong with the set up of the external source drive.

 

I've just bought a samgung 1 tb usb drive. The drive contained some of samsungs files such as disk manager etc.. 

 

I then partitioned the samsung into two 466 gig partitions using my vista laptop disk management facility.

 

So.. my damaged drive is a 320 gig sata 2.5 inch internal, with partitions  PQ service, C drive (vista) (damaged) and D drive (data)  ( ive already copied the info from D drive.

 

So I'm trying to copy an image of the C drive.

 

Here is my setup in the file manager of Parted MAgic.

 

Good Laptop with 500 gig stat 2.5 hd.  Acer Aspire 5715Z

 

sda1 - 10 G PQ service

sda2 - 137 G Acer (the ok hard drive with vista o.s I have in my working computer)

sda3 - 152 G Data ( the ok hard drive with data I have in my working computer)

sda4 - 1024 ..B ??

sda5 - 168 G RescueVol - Another partition set up on the working laptop. - THIS WAS THE ORIGINAL DESTINATION DISK THAT DIDNT WORK

 

sdb1 - 4 G Bootable USB with Parted MAgic

 

DAMAGED 320 G SATA connected with usb 2.0 sata/ ide usb adapter cablw with power.

Acer 5715Z

sdc1 - 10 G PQ service

sdc2 - 137 G Acer (Damaged and innaccessible with Parted Magic File Manager)

sdc3 - 152 G Data ( Accessible with PM file manager - already saved necessary data elswhere.. not needed now)

 

New Samsung M3 1TB usb 3.0 Slimline Portable Hard Drive

sdd1 - 466G samsung

sdd2 - 466G Rescue Disk 5 ( the section I partitioned using vista disk management to shrink the 1tb drive and label this the 'New simple Volume' - THIS IS THE NEW INTENDED DESTINATION DISK WITH THE NEW DRIVE I RECEIVED TODAY

 

sr0 (no Media)

 

 

So before I received the new 1tb drive today I only had the first two paragraphs above ie. working 500 gig laptop and Damaged 320 g Laptop connected via sata adaapter. 

 

Using the line

 

ddrescue -r 3 /dev/sdc2/ /media/sdd2/image.dd /media/sdd2/rescuelog.log

 

the process started fine but recieved the error after a few mins -  ddrescue : write error no space left on device

 

so today i set up the 1tb samsung drive and changed the line to

 

ddrescue -r 3 /dev/sdc2/ /media/sda5/image.dd /media/sda5/rescuelog.log

 

and the same error happened again.

 

I'm sure I must be doing something wrong setting up and formatting the destination drives that the damaged disk is supposed to be coppied to..

 

I'd really appreciate it if someone could point me in the right direction as I've been at this process for days now and am almost there if I can overcome this.

 

Thanks for any help posted :guitar:

 

 

 

 

 

 

 

 

 

 



BC AdBot (Login to Remove)

 


#2 burgers

burgers
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:52 AM

Posted 16 October 2013 - 03:35 PM

Just to mention my system is using Vista Home Basic with service pack 2. I do also have another pc with Windows 7 on if that is preferable to perform the dd rescue on.

 

Also, I'm now only in need of rescueing the main Outlook.pst  file on the C: windows drive that contains the last 6 months of emails I need which should be in

 

C:\Users\Myname\AppData\Local\Microsoft\Outlook

 

..and the templates for my outlook emails which should be in

 

C:\Users\Myname\AppData\Roaming\Microsoft\Templates

 

and also the contents of the desktop which has some other important files.

 

I've assumed i need to make an image of the C drive first as a precaution before recovering but perhaps there is a simpler way of getting around this problem ?

 

 

Cheers

 

p.s I wasn't sure if this was the right place to post in as the problem encompasses Vista, Internal and External hard drives etc. so if necessary I can try the topic in another forum if that helps.


Edited by burgers, 16 October 2013 - 04:02 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users