Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Just updated system games are not running correctly


  • Please log in to reply
No replies to this topic

#1 MkAdvil

MkAdvil

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:02:58 PM

Posted 10 October 2013 - 01:24 AM

Just updated my mobo, memory, and video card.
MB MSI|970A-G46 AMD970 950 AM3+ R
MEM 4Gx2|GSKILL F3-14900CL9D-8GBSR
VGA GIGABYTE|GV-N660OC-2GD GTX660 R
PSU = 630 W Bronze cert accurate to 87%

EVERYTHING is updated to latest drivers as far as i know. Yet games are still not running well at all. streaming and running multiple things while gaming is np, but the game itself is just refusing to not lag. Please help me out here guys. Usually I can fix this myself but im really mad at this point.

 

running windows update for first time since i formatted hard drive. hopefully it helps. 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users