Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

warning *nOOb* Terminal question


  • Please log in to reply
12 replies to this topic

#1 Winterland

Winterland

  • Members
  • 995 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Land of Enchantment
  • Local time:07:53 AM

Posted 24 September 2013 - 04:46 PM

So, before I posted, I did drill down several pages back into this Forum hoping to find answer and I also did the now ubiquitous Google-search but can't seem to find something obvious and simple, or simply obvious.

 

Am running Mint (14, I think) in a VM and am trying to repair a Filesystem filter driver issue with COMODO.

 

I get this helpful prompt which tell me what to run but when I type it into the Terminal window I keep receiving the "please run this script with administrator priviledges" message.

 

Now I know how to run the cmd as an Admin in Windows...but uh, I, uhh, well, I'm kinda new to the area and don't know my way around as well as I thought.

 

I've got my password for this OS, just can't seem to find a way to the cmd with admin thing...

 

Help a noob out?

 

Winterland

 

 


Photobucket removed my cool flag - idiots!

 

Every calculation based on experience elsewhere fails in New Mexico.


BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:01:53 PM

Posted 24 September 2013 - 05:37 PM

You would simply type in before the command the following:

 

sudo commandlineargumentshere such as the following

 

sudo vi /etc/passwd

 

That would open up vi with administrative / root access to edit the pssswd file.



#3 Winterland

Winterland
  • Topic Starter

  • Members
  • 995 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Land of Enchantment
  • Local time:07:53 AM

Posted 24 September 2013 - 05:56 PM

Holy Command Line Batman, that worked like a charm.    :bananas:

 

 

My COMODO is purring like a lolcat in Animal's virtual backyard!

 

 

cryptodan -  1) it's good to have you back and   2) thank you, thank you for the quick and very helpful response.

 

onward,

 

Winterland

 

 


Photobucket removed my cool flag - idiots!

 

Every calculation based on experience elsewhere fails in New Mexico.


#4 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:01:53 PM

Posted 24 September 2013 - 06:01 PM

You are welcome, and happy sudoing.



#5 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:53 AM

Posted 25 September 2013 - 09:37 AM

Not that this is your issue but for anyone else having this issue you might need to switch to root, or "su" for those that don't know, and then add your user account to the sudo'ers group first.

 

Do the following hitting enter after each line.

 

> su

> "enter root password"

> adduser "username" sudo

 

That should do it for most Linux distro's...but the group "sudo" might be slightly different on some. AKA "sudoers", but I'm not aware of any at the moment.

 

Zen



#6 Winterland

Winterland
  • Topic Starter

  • Members
  • 995 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Land of Enchantment
  • Local time:07:53 AM

Posted 27 September 2013 - 06:11 AM

Greeting Zen Seeker and thanks for the tip.

 

I just want to try to make sure I understand what you're saying...if I follow these instructions in most Linux distros (I realize there are going to be exceptions) then I will no longer need to enter my password each and every time I'm trying to install and/or change something?

 

Is this the equivalent of disabling the UAC in Windows?

 

I actually don't mind entering in my password, esp. in these Linux distros because I'm exploring several of them (all in VirtualBox) and, as you might be able to tell, I don't always *quite* know what I'm doing.

 

None the less, I appreciate your advice and please let me know if I have guessed correctly regarding your suggestion.

 

Winterland


Photobucket removed my cool flag - idiots!

 

Every calculation based on experience elsewhere fails in New Mexico.


#7 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:01:53 PM

Posted 27 September 2013 - 06:14 AM

You will still need to enter your password.



#8 Winterland

Winterland
  • Topic Starter

  • Members
  • 995 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Land of Enchantment
  • Local time:07:53 AM

Posted 27 September 2013 - 06:39 AM

OK, good to know.

 

Winterland


Photobucket removed my cool flag - idiots!

 

Every calculation based on experience elsewhere fails in New Mexico.


#9 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:53 AM

Posted 27 September 2013 - 04:14 PM

The reason I posted the above is because not all installations automatically add you to the sudo'ers group. With my version of Linux if I tried to enter "sudo vi /etc/passwd" without first adding my account to the sudo group it would say access denied and this is being reported to the administrator.

 

In Linux/Unix "su" stands for either super user or switch user...depending on who you talk to.  ;c)  (I tend to go with switch user as you can use it to change accounts; su bob)

So what your doing is acting like the root account when you execute commands. You will be prompted for the account password the first time but usually you can then use it until the terminal window is closed or an amount of time passes before being prompted for the password again.

 

"su" on its own will switch you to the root account and prompt for the root password. Not the best way to work on a Linux/Unix system but required at times. "sudo" means switch to root user and do, or super user do, command.

 

I hope that explains things a bit better.

 

Zen



#10 Winterland

Winterland
  • Topic Starter

  • Members
  • 995 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Land of Enchantment
  • Local time:07:53 AM

Posted 28 September 2013 - 07:43 AM

 

"su" on its own will switch you to the root account and prompt for the root password. Not the best way to work on a Linux/Unix system but required at times. "sudo" means switch to root user and do, or super user do, command.

 

I hope that explains things a bit better.

 

Zen

 

It does explain it, a great deal in fact so thank you.

 

I've been playing around with several Linux flavors in my VM and the great thing about creating these in that environment is that if something goes kludgey, I can just delete the profile and then reinstall, tweaking what didn't work the first time.

 

Currently I'm downloading via a torrent (and I still don't quite know what that even means...) an .iso image that once downloaded I can't seem to burn to a DVD since my virtual OS can't seem to "see" my DVD burner.

 

I'm addressing that in another post, so no need to answer that one - unless of course you've run up against the problem of course. :)

 

Inquiring minds do want to know, however, which Linux flavor you are using....if you don't mind telling.

 

Winterland


Photobucket removed my cool flag - idiots!

 

Every calculation based on experience elsewhere fails in New Mexico.


#11 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:01:53 PM

Posted 28 September 2013 - 08:01 AM

If your sudoers file does not allow access to run shutdown -h now then you will need to add that to the /etc/sudoers file on a per user basis.



#12 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:53 AM

Posted 30 September 2013 - 02:30 PM

I've been playing around with several Linux flavors in my VM and the great thing about creating these in that environment is that if something goes kludgey, I can just delete the profile and then reinstall, tweaking what didn't work the first time.

If you're using a VM or image then you should just be able to roll back to the clean state. No need to reinstall again.

 

Inquiring minds do want to know, however, which Linux flavor you are using....if you don't mind telling.

I use a x64 Debian branch called "aptosid". It's what they call an "untested" branch. Things are very current but bugs and issue come up far more often then they would using a "stable" branch.



#13 Winterland

Winterland
  • Topic Starter

  • Members
  • 995 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Land of Enchantment
  • Local time:07:53 AM

Posted 01 October 2013 - 07:10 AM

If you're using a VM or image then you should just be able to roll back to the clean state. No need to reinstall again.

 

I use a x64 Debian branch called "aptosid". It's what they call an "untested" branch. Things are very current but bugs and issue come up far more often then they would using a "stable" branch.

 

 

Well, I did not know about the roll back feature, so thank you for that.

 

And, as for the untested branch and flavors of Linux, thanks for the heads up on that as well. I was looking (just yesterday) at CrunchBang and the first thing I saw when I was about to down load the 64 bit version was the some warning that it *could* be a bit buggy at times.

 

That dynamic scared me off a bit but at the end of the day, I still downloaded it, although I haven't installed it yet in my VM.

 

Thank you gentlemen, for taking the time and giving the good help and advice.

 

We'll see you in the Forums.

 

Winterland


Photobucket removed my cool flag - idiots!

 

Every calculation based on experience elsewhere fails in New Mexico.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users