Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How to turn numlock automatic on when I put computer on?


  • Please log in to reply
10 replies to this topic

#1 Korkel

Korkel

  • Banned
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:51 PM

Posted 15 September 2013 - 01:16 PM

Hello,

 

How can I set numlock automatic on when I turn my computer on? I use an pincode to unlock my computer, and I hate it to turn numlock on first.



BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,686 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:08:51 AM

Posted 15 September 2013 - 01:55 PM

This involves a registry edit.  I would suggest backing up the registry before doing this edit.

 

How to backup Your Registry with ERUNT
  •  

 

 

  • For version with the Installer:  Use the setup program to install ERUNT on your computer.

 

  • For the zipped version you will need a program like 7-Zip to unzip the file.  

 

  • Unzip all the files into a folder of your choice.

 
Click Erunt.exe to backup your registry to the folder of your choice.
 
Note: to restore your registry, go to the folder and start ERUNT.exe

 

 

 

1)  Type in regedit.exe, when it appears in Programs above the search box right click on regedit, then click on run as administrator.
 
2)  Go to HKEY_USERS on the left hand side then DEFAULT then Control Pannel then Keyboard.
 
3)  Right click "InitialKeyboardIndicators" and click Modify and change the value to 2147483650.
 
4)  Then on your screen, mouse over to the bottom right hand corner to open the Search bar on the right hand side of the screen, (your Windows 8 side bar), and click Search.
 
5)  Search for "Control Panel", go to the Control Panel.
 
6)  Click Power Options. On the left hand side, click Choose what the power buttons do.
 
7)  Click Change settings that are currently unavailable. Uncheck the box that says Turn on fast startup (recommended), click Save Changes.
 
8)  Shut down the computer, then restart it.

Edited by dc3, 15 September 2013 - 01:57 PM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 Korkel

Korkel
  • Topic Starter

  • Banned
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:51 PM

Posted 15 September 2013 - 02:04 PM

Will tell tommorow if it works. Thanks already!



#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,686 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:08:51 AM

Posted 15 September 2013 - 02:05 PM

Let us know, I'll be around off and on.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 Korkel

Korkel
  • Topic Starter

  • Banned
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:51 PM

Posted 15 September 2013 - 02:13 PM

Let us know, I'll be around off and on.

tumblr_mduq6hk8B21qf066bo1_500.jpg

 

I think it works. :P I hope.. :-)



#6 Korkel

Korkel
  • Topic Starter

  • Banned
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:51 PM

Posted 16 September 2013 - 12:36 AM

No, it doesn't work. :(



#7 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,686 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:08:51 AM

Posted 16 September 2013 - 08:36 AM

I went back this morning and did a little more digging and found that the value should be changed to 2.  I was in a bit of a rush yesterday and it didn't click that there are two values, 0 and 2.  I'm not sure where the author of this article came up with that string of numbers.  

 

There may be an easier solution.  Check in your BIOS to see if there is the option to enable numlock on boot.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#8 Korkel

Korkel
  • Topic Starter

  • Banned
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:51 PM

Posted 16 September 2013 - 10:05 AM

I went back this morning and did a little more digging and found that the value should be changed to 2.  I was in a bit of a rush yesterday and it didn't click that there are two values, 0 and 2.  I'm not sure where the author of this article came up with that string of numbers.  

 

There may be an easier solution.  Check in your BIOS to see if there is the option to enable numlock on boot.

I don't think there is an option in the BIOS... :s



#9 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,686 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:08:51 AM

Posted 16 September 2013 - 10:19 AM

The only suggestion I can make is to set the value to a single 2.

 

If you wish to peruse more information click on the link below.

 

how to set numlock on startup windows 8 - Google Search


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#10 Korkel

Korkel
  • Topic Starter

  • Banned
  • 58 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:51 PM

Posted 17 September 2013 - 02:08 AM

Nothing is helping... :S



#11 pieterw3

pieterw3

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:51 PM

Posted 20 September 2013 - 08:10 AM

Try this:

 

  1. In Registry Editor, navigate to the following registry key:

 

HKEY_USERS\.DEFAULT\Control Panel\Keyboard

 

  1. Create the following value (DWORD):

InitialKeyboardIndicators

and give it a value of 0 (zero) or 2 (two)

 

 

  • 0 = NumLock is turned off after logon

  • 2 = NumLock is turned on after logon

 

Make sure to backup your registry before doing this

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users