Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Acer Aspire 5516 black screen


  • Please log in to reply
2 replies to this topic

#1 Twinbird

Twinbird

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:10:32 PM

Posted 14 September 2013 - 09:08 PM

Acer Aspire 5516 with black screen. The power lights come on, I can hear the HDD spin up, but the screen stays black. No output on an external monitor either. I've read that updating the BIOS to the latest version can fix this issue. I've put the BIOS exe and wph files onto a bootable usb drive and tried to boot to it (holding down the Fn key and Esc key apparently would boot the laptop to the usb and install the new BIOS) but nothing happened when I did this. 

The laptop was near an open window and got rained on. I've taken the laptop apart and cleaned it out but can't seem to fix the black screen problem (could it be something on mb is damaged?).

Thanks.



BC AdBot (Login to Remove)

 


#2 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:09:32 PM

Posted 14 September 2013 - 09:57 PM

could be a motherboard issue. The GPU could be dead. You need to pull the hard drive and check its functionality on another computer.

#3 Twinbird

Twinbird
  • Topic Starter

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:10:32 PM

Posted 14 September 2013 - 11:22 PM

Thanks for the reply, the GPU being dead seems like the issue. I will check the HDD tomorrow . 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users