Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Having to reinstall audio driver every time I connect HDMI


  • Please log in to reply
3 replies to this topic

#1 anoft

anoft

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:08:17 PM

Posted 14 September 2013 - 03:49 PM

Within the last week I have started having this problem with my laptop where I plug it in to my tv with the HDMI cable, I get the video but the sound plays through my laptop. In the sound settings the hdmi says that its not plugged in.

 

I have tried everything including rebooting the laptop with the hdmi plugged in and with it out. I have also tried rolling back and restoring my laptop and i have not installed any new software.

 

The only thing that works is uninstalling realtek audio driver and rebooting my laptop each time play something through my tv. I have tried this on my parents tv and it still happens so its got to be the laptop. The laptop is a custom laptop.

 

Please Help!

 



BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,424 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:17 PM

Posted 14 September 2013 - 05:39 PM

Why not just disable the sound/Realtek function if you aren't going to use it?

 

You can disable it/renable it any time...in Device Manager.

 

No need to uninstall drivers, if disabled.

 

Louis



#3 anoft

anoft
  • Topic Starter

  • Members
  • 45 posts
  • OFFLINE
  •  
  • Local time:08:17 PM

Posted 21 September 2013 - 08:17 PM

Why not just disable the sound/Realtek function if you aren't going to use it?
 
You can disable it/renable it any time...in Device Manager.
 
No need to uninstall drivers, if disabled.
 


When I have the laptop displaying visually on my tv it says in the sound settings that the ctve tv isn't plugged in yet when I reinstall the realtek driver it will fix the problem and I can play audio through the tv

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,424 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:17 PM

Posted 22 September 2013 - 06:52 AM

:thumbup2: , whatever works :).

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users