Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My HDD uses PIO, not DMA


  • Please log in to reply
3 replies to this topic

#1 Chicchio

Chicchio

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:07:54 PM

Posted 12 September 2013 - 03:35 AM

Hi to all !

 

I am running an old PC, windows XP pro SP3, who suddenly has become slow, at start up, shut down and generally.

I did all the "routine" checks: non virus, no startup SW unwanted, clered registry and so on. Chkdsk run all night, and so defrag, so I went to take a look in IDE primary channel, I found that it is using PIO, even if it is set as DMA if avalaible.

 

How can I fix ?

 

Thanks, Enrico



BC AdBot (Login to Remove)

 


#2 Anshad Edavana

Anshad Edavana

  • Members
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:11:24 PM

Posted 12 September 2013 - 09:48 AM

Hi

 

Please carefully read instructions from the below link. It covers the reasons and resolution for your issue.

 

http://winhlp.com/node/10



#3 Guest_RoutaSielu_*

Guest_RoutaSielu_*

  • Guests
  • OFFLINE
  •  

Posted 12 September 2013 - 08:28 PM

To enable DMA mode using the registry editor GO to start
then run input regedit then go to the following key

"HKEY_LOCAL_MACHINE\SYSTEMS\CurrentControlSet\Control\Clas
s\{4D36E96A-E325-11CE-BFC1-08002BE10318}"
The Default Value should be "IDE ATA/ATAPI controllers"
Go to "0001" key if your device is on Primary IDE Chanel
or "0002" if your device is on Secondary IDE channel
and change the MasterDeviceTimingModeAllowed or
SlaveDeviceTimingModeAllowed to 0xffffffff depending if
your
device is master or slave close registry editor.
Go to device manager select "IDE ATA/ATAPI controllers"
and the corresponding IDE chanel go to "Advanced Settings"
Tab and Set Transfer Mode to PIO and then to DMA if
available again

 

http://www.tomshardware.com/forum/147161-45-forcing-mode-primary-hard-drive

 

I have done this before on one of my old systems that had same problem. If there is another 6 errors it will go back to PIO mode again. If that happens try to replace the IDE cable to your HDD. If replacing the IDE cable does not correct the problem you may need to replace the HDD.

 

**As a note, you should always have a good backup of your system registry before making any changes. A bad change in system registry can cause your system to not boot up.



#4 Chicchio

Chicchio
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  

Posted 13 September 2013 - 03:42 AM

Hi

 

Please carefully read instructions from the below link. It covers the reasons and resolution for your issue.

 

http://winhlp.com/node/10

 

Many thanks to both for the help.

 

After carefully reading all the page at winhlp I tried the fix with the script, and it worked.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users