Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problems with Google Earth


  • Please log in to reply
4 replies to this topic

#1 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,423 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:31 PM

Posted 03 September 2013 - 11:17 AM

ASUS M4N68T-M motherboard,

4Gb DDR3 RAM

Win 7 64bit SP1

 

A couple of times over the last perhaps three  months, Google Earth has gone strange, see image attached. Instead of the globe appearing and then spinning round to its default position of over the UK, since I live there, it has stopped centred over the South end of the North Atlantic with a gray oval in the centre of the globe and a downward pointing gray arrow on each side of the globe.

 

The normal navigating tools don't work, but you can rotate the globe by moving the cursor up and down these gray arrows.

 

The first time it happened, I uninstalled it and re-installed and it worked normally. This time, it re-installed with exactly the same problem.

 

Anybody got any ideas as to what is causing this, and any thoughts as to a solution ?

 

xgrc.th.jpg

 

Chris Cosgrove



BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove
  • Topic Starter

  • Moderator
  • 6,423 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:31 PM

Posted 04 September 2013 - 06:49 PM

I think I have solved this problem !  I took a long hard look around 'Options'

 

'Tools / Options / Navigation'. On the left hand side of the navigation options screen there is a panel for 'Non-mouse Controller' which was ticked. Un-ticking this control seems to have freed up the normal methods of control and the gray arrows and the gray blob have gone. Once again its default starting position is centred over the UK and the zoom bar and direction of movement control are responding to the mouse.

 

Chris Cosgrove



#3 Animal

Animal

    Bleepin' Animinion


  • Site Admin
  • 34,828 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where You Least Expect Me To Be
  • Local time:07:31 AM

Posted 08 September 2013 - 06:57 PM

Thank you for sharing a potential fix. Let us know if it ultimately ends up being the fix.

The Internet is so big, so powerful and pointless that for some people it is a complete substitute for life.
Andrew Brown (1938-1994)


A learning experience is one of those things that say, "You know that thing you just did? Don't do that." Douglas Adams (1952-2001)


"Imagination is more important than knowledge. Knowledge is limited. Imagination circles the world." Albert Einstein (1879-1955)


Follow BleepingComputer on: Facebook | Twitter | Google+

#4 Chris Cosgrove

Chris Cosgrove
  • Topic Starter

  • Moderator
  • 6,423 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:03:31 PM

Posted 11 September 2013 - 04:46 PM

Yes, this seems to be the answer. I am still left with the question 'How did the box get ticked ?' in the first place, but that is not terribly important.

 

One useful side effect. I got to thinking 'Non-mouse controller' ?  Since I play flight sims, let's tick the box and try my joystick - it works !  A very quick trial shows you can zoom in and out and move around using the joystick and its buttons as navigation tools but I think it would take a fair bit of practice to get as accurate as I am with a  mouse. But useful to know. And ticking this box briings back the gray dot and the two arrows.

 

Mainly, I am glad I got it back to working normally. Google Earth is an incredibly useful tool. My wife and I are going to France in October with the object - apart from enjoying ourselves - of photographing some 2,500 gravestones. Since these are almost all in the open air, light is critical for a good image. GE cannot do anything about whether or not the sun is going to shine, but just being able to, in many cases, see the orientation of the stones suggests the optimum time of day for shooting the images.

 

Chris Cosgrove



#5 skywagon1

skywagon1

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:31 AM

Posted 28 July 2015 - 12:24 PM

Google Earth (GE) Rotates on Start-up . . . .

 

Chris is exactly correct on his analysis and steps to correct the GE start-up problem; un-checking a non-mouse controller. 

It must have something to do with the latest versions of GE that I have on my W7 PC.

I had a hand controller plugged in via USB that was used with an aviation SIM application.  In the past, this controller never caused a problem when unused and left plugged in.  Some later version changes from GE or other form of updating caused the problem. Thanks, Chris

Dave






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users