Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I have downloaded a virus that has changed my shell32.dll file. Please help.


  • Please log in to reply
1 reply to this topic

#1 Jubai9

Jubai9

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 18 August 2013 - 11:01 PM

Hello thank you for taking the time to read this. I use a laptop which runs off windows vista business edition. I recently was bored of the old themes that windows had so I tried to download a custom one I read many guides and they also said I had to change the shell32.dll file in the windows/system32 folder so I found a few ones and that I liked but shortly after I decided to change back to the original theme because the font was too small to read. But I had deleted the original shell32.dll file so I googled download windows vista shell32.dll and found this site http://www.dll-files.com/dllindex/dll-files.shtml?shell32 and I downloaded it and it seemed quite professional so I used it and everything was fine until I restarted my laptop. Once I start it up it runs smoothly until it eventually turns to a black screen and a message pops up saying
logonUI.exe - Entry Point Not Found "The procedure entry point SHCreateShellItemArray could not be located in the dynamic link library SHELL32.dll."
I then click okay. The windows symbol and noise appears and my accounts show up normally. When I click on either of them and log on, the welcome sign appears and then a white box pops up saying
explorer.exe -Ordinal Not Found "The ordinal 790 could not be located in the dynamic link library SHELL32.dll."
It then says windows explorer has stopped working and also task scheduler engine has stopped working. I am unable to open task manager to run explorer.exe and the same messages appear. I have tried running in safe mode and I have tried command prompt neither work also I have tried to use F8 when it first starts up that also does not work. I do not know what else to do. Please help me if you know a fix or if it is broken or if it can be fixed if I take it in somewhere. Thanks again.


Edited by hamluis, 19 August 2013 - 07:52 AM.
Moved from Vista to Am I Infected - Hamluis.


BC AdBot (Login to Remove)

 


#2 SleepyDude

SleepyDude

  • Malware Response Team
  • 2,996 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:12:22 AM

Posted 19 August 2013 - 06:29 AM

Hi,
 
If you press F8 during boot can you access a screen like this?
z9OYbh0GvSPmtr1shF9Q8mO48.png

 

Select Repair Your Computer if you don't seen the option can you boot in Safe Mode with Command Prompt?


Edited by SleepyDude, 19 August 2013 - 06:30 AM.

• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users