Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot Start in Safe Mode, Repair or Restore. Where to go from here?


  • Please log in to reply
2 replies to this topic

#1 ViridianScourge

ViridianScourge

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:06:16 PM

Posted 12 August 2013 - 05:20 PM

All signs point to a pretty nasty infection that somehow edited my registry.

 

As stated, Trying to boot in safe mode gets me the BSOD. Trying to Repair results in a 'Cannot Repair' message. Trying to Restore from a Restore Point gives me a similar error.

 

When I try to start it normally, I get this error:

 

"The program can't start because COMCTL32.dll is missing from your computer. Try reinstalling the program to fix this problem."

 

I do, however, have a laptop and an internal hard drive dock. I've docked it, ran Avast and Malwarebytes and got a few hits, but nothing that helped with the startup problem (After 2 days Avast was STILL searching, as a hard drive connected via USB is pretty freakin' slow), so I ended up ending that one prematurely.

 

I also ran Windows "Official" Malicious Software Removal Tool, and strangely it automatically restarted my computer about 4 hours in both times I ran it.

 

Unfortunately, reformatting is strongly undesirable

 

I tried finding a tool that could rebuild/repair/clean the registry, but it seems most programs do the local registry, not a secondary registry on another drive.

 

Any help is GREATLY appreciated. Thanks for reading.


Edited by hamluis, 14 August 2013 - 09:35 AM.
Moved from Win 7 to Am I Infected - Hamluis.


BC AdBot (Login to Remove)

 


#2 sikntired

sikntired

  • Members
  • 1,075 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:05:16 PM

Posted 12 August 2013 - 05:41 PM

Run the sfc /scannow System File Checker command to replace a missing or corrupt copy of the comctl32.dll file. If this DLL file is provided my Microsoft, the System File Checker tool should restore it.

 

 Here's a good tutorial: http://www.sevenforums.com/general-discussion/298689-comctl32-dll-missing.html

 

 

Regards.................


Edited by sikntired, 12 August 2013 - 07:12 PM.


#3 ViridianScourge

ViridianScourge
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:06:16 PM

Posted 13 August 2013 - 08:46 PM

Alright, so I gave this a shot. Something I should have mentioned before: The laptop I'm using is XP while the "problem child" hard-drive-OS is 7.

 

So, on m XP machine with my Windows 7 hard drive docked, I used th sfc /scannow command. Took about 2.5 hours, and asked me for an XP disc (as it was doing the local OS first).

 

I was never asked for the Windows 7 disc. Would an XP sfc scan even know what a Windows 7 OS is? I don't even know if it went through that hard drive's OS or not.

 

I did, however, try a few extra commands that were in that article, much to no avail. I tried both:

sfc /scannow /offbootdir=f:\
and
sfc /scannow /offwindir=f:\windows

(The docked drive was the F drive, of course). Neither of these commands gave me the popup that the normal sfc /scannow did. Not sure if I typed them wrong or the command simply couldn't read a Windows 7 OS.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users