Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Think I deleted SP1 and .Net Framework 3.5 SP1 fails to install


  • Please log in to reply
1 reply to this topic

#1 fixcompsafe

fixcompsafe

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Local time:02:02 PM

Posted 08 August 2013 - 02:48 PM

Hi. I have Windows XP Professional Version 2002 SP3.

I think I recently deleted SP1 with Revo Uninstaller thinking it was unnecessary. I don't see any MSXL SP1 in my Add/Remove programs. I tried to do Windows Automatic updates and  the following items failed to install:

-Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions2.0 through 3.5 (KB951847) x86

-Security Update for Microsoft .NET Framework 3.5 SP1 on Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008 x86 (KB2416473)

-Update to .NET Framework 3.5 Service Pack 1 for the .NET Framework Assistant 1.0 x86 (KB963707)


And because of that I used the .Net Framkework Remover Tool, which deleted all the .Net Framkeworks from my system. Now when I go to Windows update it says "No high-priority updates for your computer are available. To check for optional updates, return to our home page and click Custom."

I think I messed up my computer really badly. And I'm not sure I have all the necessary MSXL. These are all the MSXL that are listed in Add/Remove programs:
MSXL 4.0 SP2 (KB954430)
MSXL 4.0 SP2 (KB973688)
MSXL 4.0 SP3 Parser
MSXL 4.0 SP3 Parser (KB2758694)


Edited by fixcompsafe, 08 August 2013 - 02:50 PM.


BC AdBot (Login to Remove)

 


#2 .X.

.X.

  • Members
  • 490 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:02:02 PM

Posted 08 August 2013 - 05:06 PM

Why do you need MSXL 4.0? It's not a requirement unless you have a program that needs it in order for it to run, same goes for .NET Frameworks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users