Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Web sites not working properly in IE8, no javascript?


  • Please log in to reply
7 replies to this topic

#1 cmh123

cmh123

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:40 AM

Posted 06 August 2013 - 05:32 PM

Hi, 

 

I'm having a problem with web sites that don't work in Internet Explorer 8, but do work when I use other browsers like Firefox, Opera etc.

 

For example with IE8 when I go to the hotmail sign in page it is just a blank white screen, and youtube videos are just a black box. I think this might be a problem with javascript not working?

 

This problem started just after I had some intrusion attempts that Norton Internet security warned about. I have done all malware scans, and posted DDS logs and lots of other logs in the malware removal section of the forum, and they are all clean, so it doesn't seem to be a malware infection.

 

I've uninstalled IE8 and then installed a new version, I've also run a microsoft fixit that resets IE8, but the problem remains. I've checked in the internet options menu that scripting is enabled.

 

What could have caused this problem, and is there anything I can do to fix it? 

 

I'm using an old Dell Dimension 4600 desktop, intel pentium 4 3.06 GHz CPU, 512MB RAM, with windows XP SP3.

 

Thanks very much for any help. :)



BC AdBot (Login to Remove)

 


#2 dan786

dan786

  • Members
  • 152 posts
  • OFFLINE
  •  
  • Local time:12:40 AM

Posted 06 August 2013 - 05:52 PM

it sounds like flash player not java because i had similer problem but i uninstalled ie10 and tested in ie9 work good then reinstalled. but to what your saying about reinstalling hopfully some one with more xp on this can get to you


Edited by dan786, 06 August 2013 - 05:55 PM.

gigabyte 990fxa ud7, amd fx 4100 quadcore , 8gb corsair ram, msi n570gtx pe/oc twin frozer III, pc power cooling950 silencer psu, wd 1tb hd
win 7 prem 64bit


#3 cmh123

cmh123
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:40 AM

Posted 07 August 2013 - 08:32 AM

Thanks Dan, maybe it is a problem with flash, I'm not sure. I updated my Java a few days ago to the latest version, but I think java is different from javascript and not related, is that right? As you can tell I don't know much about this!

 

I tried uninstalling then downloading a new copy and reinstalling, but that didn't help. I can't upgrade past IE8 because I'm using windows XP.



#4 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:12:40 AM

Posted 07 August 2013 - 10:45 AM

Java and Javascript are not related but are frequently confused. The Javascript errors are coding errors on the website and they only come up on IE. You won't get them on Chrome or Firefox. This kind of nonsense is why a lot of users stopped using IE.



#5 dan786

dan786

  • Members
  • 152 posts
  • OFFLINE
  •  
  • Local time:12:40 AM

Posted 07 August 2013 - 11:07 AM

have you uninstalled flash player then uninstalled ie , then reinstalled flash? and see if it worked then reinstall ie8 if it worked in ie7


gigabyte 990fxa ud7, amd fx 4100 quadcore , 8gb corsair ram, msi n570gtx pe/oc twin frozer III, pc power cooling950 silencer psu, wd 1tb hd
win 7 prem 64bit


#6 cmh123

cmh123
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:40 AM

Posted 09 August 2013 - 08:29 PM

Hi, i removed flash player and then reinstalled it but that didn't fix the problem. But it did help clarify that the problem is lack of javascript, because when I went to the Adobe web site to download flash the 'download now' button didn't appear, and on reading the adobe faq this is because javascript is not enabled. I've checked in 'internet options' and scripting is showing as enabled, but is obviously not working properly.

 

I also removed IE8 again, and the problem is still present in IE7.

 

Frank thanks for the info about javascript. I find it funny that microsofts own web sites, eg hotmail, are affected by this. You would think they would make their web sites work with their own browser! But then I suppose they are deliberately trying to make IE8 obsolete, so people will upgrade from Windows XP. Well their evil plan didn't work, I am just switching to a different browser instead! :D

 

Thanks both of you for your replies.



#7 TulsaRose

TulsaRose

  • Members
  • 367 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Tulsa OK
  • Local time:11:40 PM

Posted 10 August 2013 - 05:52 AM

These are the instructions for turning on JavaScript in IE8.  (Copied from eHow.com.)   Maybe you missed this step?
 

Instructions

  1. Internet Explorer Instructions
    • 1

      Open the Interneticon1.png Explorer application from the "All Programs" list in the Start menu.

    • 2

      Click on "Tools" in the top menu bar and choose "Internet Options."

    •  
    • 3

      Go to the "Securityicon1.png" tab at the top of the window and click on the "Custom Level" button.

    • 4

      Scroll down to the "Scripting" category and click on the "Enable" option next to "Active Scripting." JavaScript is now enabled.

Read more: http://www.ehow.com/how_4812316_turn-javascript-windows-xp.html#ixzz2bYudXx6r


Edited by TulsaRose, 10 August 2013 - 05:53 AM.

WinXP Pro sp3 \ Firefox, Panda, MBAM, SAS, SpywareBlaster


#8 cmh123

cmh123
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:40 AM

Posted 10 August 2013 - 01:00 PM

Hi, thanks I've already done that, and scripting is showing as enabled in that menu. But it just isn't working.

 

I've also reset IE8 a few times, which sets it back at default settings including scripting enabled, but that doesn't help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users