Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Is My Mouse Broke?


  • Please log in to reply
3 replies to this topic

#1 Zadeth

Zadeth

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United Kingdom
  • Local time:08:04 PM

Posted 03 August 2013 - 08:10 AM

My Roccat Kone [+] keeps lagging and stuttering and when I booted my PC today, I got an error saying Microsoft Keyboard and Mouse Center had stopped working and it was restarting. After this, the mouse began to lag again; but there is no keyboard lag. I have plugged in a normal usb wireless mouse and so far it does not seem to lag or stutter.

 

Update - both mice are plugged in and when I go to do a circle, the usb mouse works but my normal mouse stutters.



BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,364 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:12:04 PM

Posted 03 August 2013 - 02:53 PM

Have you tried uninstalling and then reinstalling the driver for this mouse?


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 Zadeth

Zadeth
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United Kingdom
  • Local time:08:04 PM

Posted 03 August 2013 - 02:55 PM

The drivers of this mouse play up a lot. When you go to update, it doesn't go through successfully and then the mouse doesn't work in that USB port. I'm down to the last port on the back of the computer. Anyhow, it seems it is a known problem with this mouse and I read on multiple places that removing a sticker on the bottom would help. It has seemed to as it's not acting up since.

 

Thanks.



#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,364 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:12:04 PM

Posted 03 August 2013 - 03:10 PM

I understand that a short jack sledge hammer will resolve this issue with the added benefit of a cathartic experience. :whistle:


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users