Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Excel 2003 Hangs When Trying To Open Or Save As Files - Solved


  • Please log in to reply
2 replies to this topic

#1 hotshot309

hotshot309

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Location:Central Illinois
  • Local time:05:11 AM

Posted 20 April 2006 - 05:22 PM

I'll try to make this as concise as I can:

Problems/steps taken:
- Running Windows XP SP 2/Office Pro 2003.
- User noticed problem this morning; some corporate patches or updates may have been applied since yesterday (not sure).
- Initially couldn't open Excel files by any method. Excel would hang and the task would have to be ended.
- Used Add/Remove Programs on Office 2003 and chose Repair. Didn't notice a change. Then did Change on Office components and unchecked Excel to remove it. Later re-checked Excel to put it back on.
- Noticed that I could now open Excel files by double-clicking on them or opening from recent Excel files list. File | Open or toolbar Open button still make Excel hang.
- Also noticed that Save As command from the file menu (or the toolbar, if you add a toolbar Save As button) also makes Excel hang.

Notes:
- There are no files in XLSTART under the Office11 folder or the user's profile. There are no .xlb (customized toolbar) files on the system. There are also no Add-ins running and never were.
- Running Filemon.exe (from Sysinternals.com) shows that several files are not found as Excel tries to Open or Save As, but I'm not sure I see any unfound files that should make any difference. It keeps looking for shell32.dll repeatedly after it's already been found in C:\Windows\system32, where the file does reside.

--------

SOLUTION (my boss found this, and it worked):

This was caused by a recent Microsoft patch. There were apparently also about 40 instances of verclsid.exe running, and some other problems. For info on how to fix this, see the Microsoft Knowledgebase Article with the fix (http://support.microsoft.com/kb/918165). Here is an excerpt:

SYMPTOMS
After you install security update 908531 (security bulletin MS06-015), you may experience one or more of the following problems:

• You cannot access special folders such as "My Documents" or "My Pictures."
• Microsoft Office applications stop responding when you try to save or to open Office files in the "My Documents" folder.
• Office files that are located in the "My Documents" folder cannot be opened.
• If you open a file by clicking Open on the File menu, the application stops responding.
• When you type an address in the Address box in Microsoft Internet Explorer, nothing happens.
• When you right-click a file and then click Send To, nothing happens.
• When you expand a folder in Windows Explorer, nothing happens.
• Some third-party applications stop responding when you open or save data in the “My Documents” folder.

To see security bulletin MS06-015, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/...n/ms06-015.mspx

Hotshot309


BC AdBot (Login to Remove)

 


#2 rigel

rigel

    FD-BC


  • Members
  • 12,944 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:South Carolina - USA
  • Local time:09:11 AM

Posted 21 April 2006 - 03:03 PM

Hi hotshot309,

Thank you for posting your fix. It helps to see what the fix was.

rigel

"In a world where you can be anything, be yourself." ~ unknown

"Fall in love with someone who deserves your heart. Not someone who plays with it. Will Smith


#3 hotshot309

hotshot309
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Location:Central Illinois
  • Local time:05:11 AM

Posted 21 April 2006 - 05:29 PM

Rigel--glad I could help. I hope it helps someone else. I figure, I spent enough time not knowing what the problem was. :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users