Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Conexant SmartAudio HD Sound Card - Enable Stereo Mix


  • Please log in to reply
9 replies to this topic

#1 wildzero

wildzero

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:04:06 PM

Posted 26 July 2013 - 11:53 PM

I recently bought a Dell Inspiron running Windows 8 which has a Conextant SmartAudioHD sound card. I wanted to record some audio off the sound card, and realized that this sound card does not allow Stereo Mix to be enabled, so recording software like Audacity has nothing to record from. I did some research, and I found some examples of Toshiba users modifying driver code in order to enable Stereo Mix. However, I was unable to find anything Dell or Windows 8 specific.

 

I was hoping someone might be able to give me some ideas on how to enable the Stereo Mix on a Dell Inspiron PC running Windows 8.

 

Thanks for helping!

 

Dell Inspiron

Windows 8

Conexant SmartAudio HD v8.54.40.0

 

 



BC AdBot (Login to Remove)

 


#2 wildzero

wildzero
  • Topic Starter

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:04:06 PM

Posted 27 July 2013 - 10:03 PM

After further research I came across this thread

 

http://en.community.dell.com/support-forums/laptop/f/3517/p/19483405/20262660.aspx#20262660

 

The instructions are for Windows 7, though I used it as a general template and improvised when Windows 8 changes popped up. It worked very well and I am recording off my sound card with Audacity with no issues. For anyone who may want to make this change, modified instructions for this are below (thanks to the author of the link above for doing 99.9% of the work):

 

  • Ensure you have the Conexant SmartAudio HD driver installed. To check, open Device Manager > Sound, Video and Game Controllers
  • Find the location of the driver file. Mine was called chdrt.inf and it was located in: C:\Windows\System32\DriverStore\FileRepository\chdrt.inf_amd64_acb009d1496f236f (It might vary from one computer to another and also be called something else)
    • If you are not sure where your .inf file is located you could do a Windows search for text in files of the string: EpSettings\StereoMixEnable. It will most likely be a file with the extension .inf and be located in a sub folder of the System32 folder.
  • Windows will not let you modify the chdrt.inf file without changing file permissions.
    • Right click on chdrt.inf filename and select Properties
    • Go to the Security tab and click on the Edit button
    • In the "Groups or user names" box, highlight the Users profile
    • In the "Permissions for Users" box, check the "Allow" checkbox next to "Full Control". This will place check boxes in all permissions.
    • Click Apply
  • Right click on chdrt.inf filename and select "Open With" then choose Notepad
  • Hit Control+F then search for StereoMixEnable to find the three lines:

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00

  • Delete the semi-colons (;) at the beginning of each line and save the file (Save as chdrt.inf with All Files selected as file type)
  • This step is VERY important. You must change back the file permissions to the way they were. Please follow these directions exactly or you could put your computer at risk:
    • Right click on chdrt.inf filename and select Properties
    • Go to the Security tab and click on the Edit button
    • In the "Groups or user names" box, highlight the Users profile
    • In the "Permissions for Users" box, uncheck the "Allow" checkbox next to "Full Control". This will remove checks in the checkboxes for all permissions
    • Check the "Allow" checkbox next to "Read & Execute" and "Read"
    • Click Apply
  • Re-install the driver:
    • Open Device Manager > Sound, Video and Game Controllers
    • Right click on Conexant SmartAudio HD
    • Select Update Driver Software
    • Select Browse my computer for driver software
    • Select Let me pick from a list of drivers on my computer
    • Click "Have Disk"
    • Click "Browse"
    • Find the location of the .inf file you just edited (C:\Windows\System32\DriverStore\FileRepository\chdrt.inf_amd64_acb009d1496f236f in my case), select the chrdt.inf file and click OK
  • Reboot the computer
  • Stereo Mix can now be seen by right clicking the speaker icon on your Task Bar and selecting Recording Devices. If you don't see it listed, right click on empty space and select Show Disabled and Show Disconnected Devices

If you run into any issues, check the link for the Windows 7 instructions, he gives you some tips if you hit specific roadblocks.


Edited by wildzero, 27 July 2013 - 10:05 PM.


#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,738 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:03:06 PM

Posted 28 July 2013 - 12:34 PM

Glad you resolved it, thanks for posting that link...it may help others in a similar situation.

 

Happy computing :).

 

Louis



#4 DavidHW

DavidHW

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:06 PM

Posted 10 May 2016 - 11:53 AM

Thanks very much, wildzero! I had been trying for some time to do this in Windows 10 on a Toshiba laptop, and have now succeeded thanks to your post. There's one very important point to make, and one less serious.

 

Most important: you have to look for all instances of the three lines

 

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00

 

I took out the semi-colons on my first attempt but it failed - because I hadn't realised that the lines might be repeated lower down. The point is made in the Windows 7 original post, but rather quietly. Everything went very smoothly after that.

 

The way permissions and owners are changed is different in Windows 10 - my "owner" was SYSTEM, for instance, and the choices offered by the UI are slightly different.

 

Anyway, thanks very much again - you've given back one of my favourite uses of the computer!

Kind regards,

David



#5 davidhuang

davidhuang

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:06 PM

Posted 20 December 2016 - 06:13 PM

Thank you all for the info.

 

I have Lenovo Z40-70 with Windows10. The same problem with DavidHW. Correct all instances of the three lines is critically helpful.

 

Just one more comment if you try the driver update before you see this post. (Hope you could see this post first if you google it in the beginning.)

 

You may find multiple *.inf files with \EpSettings\StereoMixEnable included due to different versions of the driver.

 

Make sure you have corrected them all or delete the older ones (you can check their modification date to decide which is older.).  Deletion of the folder may require the security change as well. Or you can just click "delete the drivers" when you are deleting the device (see the next paragraph). But you have to download a correct driver for your system (this should not be a problem for you if you have not solved your problem before seeing my post.).

 

Either way, for my case I have to go to Device Manager to delete the device first and keep Scanning for hardware changes until the *.inf I changed is automatically installed by the system (You can check this by Right Click->Properties->Events and check the latest event to see if you find the name of your *.inf. It may take a few minutes.). Without deleting the device first, a single update driver will not work since the system keeps telling me that my driver is already up to date and will not do the re-installation.

 

My feeling is that for Windows 10, Conexant do not want you to use stereo mix so that to make it work is very tricky.


Edited by hamluis, 22 December 2016 - 11:25 AM.
Removed unnecessary quotebox - Hamluis.


#6 Overkillian

Overkillian

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:06 PM

Posted 29 August 2017 - 06:25 PM

Something wrong with asking about this? I see the post has been deleted after I posed a questions about getting to change the user permissions in Win10.

I tried to follow the above instructions as to "modify the chdrt.inf file" but was prohibited from changing the user permissions as the options were all greyed out, thus I couldn't proceed with the guide.



#7 JohnC_21

JohnC_21

  • Members
  • 23,635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:06 PM

Posted 29 August 2017 - 06:31 PM

Not deleted. It was split to a new thread.

 

https://www.bleepingcomputer.com/forums/t/654736/audio-permission-issues/



#8 Overkillian

Overkillian

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:06 PM

Posted 04 September 2017 - 02:18 PM

Oh. I didn't see any notice on that, so had no clue. Thanks for telling!



#9 nyil

nyil

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:06 PM

Posted 12 March 2018 - 12:59 PM

Hello,

 

thanks for all in this topic, but I have to supplement it !

 

 

I have an Lenovo yoga 460 1,5 years old laptop with Windows 10, and I didn't find at all any chdrt.inf file but I do find C:\DRIVERS\WIN\AUDIO\R05AD05W\

T15Plmwa (Setup information) ( .inf ) file, this file equal chdrt.inf, so I needed this file editing. When I tried to install the modified T15Plmwa.inf file  with device manager it wasn't success some error message popped up. After that I again googled and found this, what solve my stereo mix issues completely:

http://www.razvan.id.au/helpful/stereo-mix-on-conexant-hd-sound-card-and-windows-8.html

 

Before you wanted to install the driver software with the new modified T15Plmwa.inf file you have to start your laptop in advanced start up mode you see at the link above !

After the installation you have to restart the laptop an the result is unbeleivable: you will see the stereo mix icon at speaker icon at the system tray.

 

sorry but I can't paste any image in this post



#10 batmanlovesuperman

batmanlovesuperman

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:06 AM

Posted 25 June 2018 - 08:10 PM

After further research I came across this thread

 

http://en.community.dell.com/support-forums/laptop/f/3517/p/19483405/20262660.aspx#20262660

 

The instructions are for Windows 7, though I used it as a general template and improvised when Windows 8 changes popped up. It worked very well and I am recording off my sound card with Audacity with no issues. For anyone who may want to make this change, modified instructions for this are below (thanks to the author of the link above for doing 99.9% of the work):

 

  • Ensure you have the Conexant SmartAudio HD driver installed. To check, open Device Manager > Sound, Video and Game Controllers
  • Find the location of the driver file. Mine was called chdrt.inf and it was located in: C:\Windows\System32\DriverStore\FileRepository\chdrt.inf_amd64_acb009d1496f236f (It might vary from one computer to another and also be called something else)
    • If you are not sure where your .inf file is located you could do a Windows search for text in files of the string: EpSettings\StereoMixEnable. It will most likely be a file with the extension .inf and be located in a sub folder of the System32 folder.
  • Windows will not let you modify the chdrt.inf file without changing file permissions.
    • Right click on chdrt.inf filename and select Properties
    • Go to the Security tab and click on the Edit button
    • In the "Groups or user names" box, highlight the Users profile
    • In the "Permissions for Users" box, check the "Allow" checkbox next to "Full Control". This will place check boxes in all permissions.
    • Click Apply
  • Right click on chdrt.inf filename and select "Open With" then choose Notepad
  • Hit Control+F then search for StereoMixEnable to find the three lines:

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00

  • Delete the semi-colons (;) at the beginning of each line and save the file (Save as chdrt.inf with All Files selected as file type)
  • This step is VERY important. You must change back the file permissions to the way they were. Please follow these directions exactly or you could put your computer at risk:
    • Right click on chdrt.inf filename and select Properties
    • Go to the Security tab and click on the Edit button
    • In the "Groups or user names" box, highlight the Users profile
    • In the "Permissions for Users" box, uncheck the "Allow" checkbox next to "Full Control". This will remove checks in the checkboxes for all permissions
    • Check the "Allow" checkbox next to "Read & Execute" and "Read"
    • Click Apply
  • Re-install the driver:
    • Open Device Manager > Sound, Video and Game Controllers
    • Right click on Conexant SmartAudio HD
    • Select Update Driver Software
    • Select Browse my computer for driver software
    • Select Let me pick from a list of drivers on my computer
    • Click "Have Disk"
    • Click "Browse"
    • Find the location of the .inf file you just edited (C:\Windows\System32\DriverStore\FileRepository\chdrt.inf_amd64_acb009d1496f236f in my case), select the chrdt.inf file and click OK
  • Reboot the computer
  • Stereo Mix can now be seen by right clicking the speaker icon on your Task Bar and selecting Recording Devices. If you don't see it listed, right click on empty space and select Show Disabled and Show Disconnected Devices

If you run into any issues, check the link for the Windows 7 instructions, he gives you some tips if you hit specific roadblocks.

Thanks for the answer, but you could just use Notepad as administrator and it can easily edit any file (a trick back when I was editing hosts file in Windows)






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users