Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop Won't Start


  • Please log in to reply
No replies to this topic

#1 Twinbird

Twinbird

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:04:26 PM

Posted 23 July 2013 - 04:07 PM

I have a Toshiba Satellite Pro S500 Laptop that won't start. I bought a new power jack and installed it into the laptop and tested it with a voltmeter, it works fine, and the laptop did in fact start up with the new adapter and power jack. A couple days later I try to start up the laptop again, but it won't start. I took the laptop apart again and tested the power jack and also tested the power adapter, both are working fine so I don't know why the laptop won't start up again.

 

Edit: It seems the mobo is dead, will have to purchase a new laptop.


Edited by Twinbird, 24 July 2013 - 12:56 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users