Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

No option for dual boot after xp recovery.


  • Please log in to reply
9 replies to this topic

#1 Ket

Ket

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 22 July 2013 - 05:38 AM

I have a netbook with dual boot between xp and linux mint. I recently did a recovery to factory settings for the xp partition and I ended up having to repair mbr, which I did successfully. Now I don't get prompted to choose between xp and mint at start-up. I tried to fix it by using boot-repair-disk (on a flash drive) but although it said it was fixed, the pc still boots directly into xp without prompt for dual boot. Any suggestions?

Notes: No optical drive on netbook

Please try to be as detailed as possible cause I don't really know anything about linux.



BC AdBot (Login to Remove)

 


#2 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:10:35 AM

Posted 22 July 2013 - 07:02 AM

try this reboot you computer and keep tapping on the f8 key. hopefully this will bring up your boot menu. if it does log into mint. open a mint terminal and type sudo update-grub.


quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#3 Ket

Ket
  • Topic Starter

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 22 July 2013 - 07:05 AM

try this reboot you computer and keep tapping on the f8 key. hopefully this will bring up your boot menu. if it does log into mint. open a mint terminal and type sudo update-grub.

It only gives me the option for xp. Can I do it through a live usb?


Edited by Ket, 22 July 2013 - 07:08 AM.


#4 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:10:35 AM

Posted 22 July 2013 - 07:49 AM

maybe try this

http://fosswire.com/post/2009/05/restoring-overwritten-grub/


quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#5 Ket

Ket
  • Topic Starter

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 22 July 2013 - 08:29 AM

I will need some help to determine  which partition I should mount. Gparted shows this:

 

52c8.jpg

 

 

If I read right, it seems as if the windows recovery also deleted the mint partition (probably the unallocated 48.04 GB). Could this be the case for not having the dual boot option? And if this is the case, is it maybe easier to re-install mint? I think there is an easy option to install linux above an existing installation. How do I do this?


Edited by Ket, 22 July 2013 - 08:30 AM.


#6 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:10:35 AM

Posted 22 July 2013 - 01:33 PM

you could reformat /dev/sda3 into ext4 and install there. make sure that u make this partition the mount point when you reinstall mint. 


quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#7 Ket

Ket
  • Topic Starter

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 22 July 2013 - 02:07 PM

I re-installed mint but it installed on the unallocated 48.04 G. I am not sure what is the sda3 but I can't seem to be able to touch it. I think it is swap and the 48.04 together, cause when I choose it on the list, both swap and sda6 get highlighted. Is that right?

 

That's how it looks now.

 

gzkm.jpg



#8 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:10:35 AM

Posted 22 July 2013 - 03:41 PM

looks good to me you have mint installed on /dev/sda6 ext4. you able to get the grub menu? also i think you can format the extended to whatever you want and but in another linux distr if you want(you might have to format that using gparted when loged into mint). just keep your mount point like you have it now. good luck


quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#9 Ket

Ket
  • Topic Starter

  • Members
  • 145 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 22 July 2013 - 05:49 PM

It works fine, but I don't think the extended is a partition by itself. When I right click on it on gparted, all choices are grayed out. I think it is both sda5 and sda6 together (hence the little arrow next to it). It is rather confusing the sda3 naming, but it's like it is not there and I can't touch it. When I highlight the names the respective partitions are simultaneously highlighted. When I highlight sda3, both sda5 + sda6 partitions are highlighted (the small-dash frame around the partitions in the picture above).

 

Thank you very much for all your help. :)



#10 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:10:35 AM

Posted 23 July 2013 - 06:59 AM

my bad you are right


quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users