Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Changing Permissions in Ubuntu


  • Please log in to reply
4 replies to this topic

#1 EricMon

EricMon

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:03:07 AM

Posted 15 July 2013 - 09:30 AM

Hello all. I am currently working on a project and I am trying to move files into the /var/www folder. However, when I do this, it says that I do not have permission. Can anyone help out?



BC AdBot (Login to Remove)

 


#2 Bezukhov

Bezukhov

    Bleepin' Jazz Fan!


  • Members
  • 2,698 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Providence, R.I.
  • Local time:04:07 AM

Posted 15 July 2013 - 10:31 AM

I think this is what I did. It was a while ago, and my aging brain isn't what  it used to be. (What a way to inspire confidence!)

 

Anyways these commands will give you the option to use a folder as root when you right click on it.

sudo add-apt-repository ppa:noobslab/apps

sudo apt-get update

sudo apt-get install open-as-administrator

When thats all done type

nautilus -q

to restart nautilus.

 

I have the "Open as Administrator" on my system and just played around with my /var/ folder and no problems at all.

 

ETA: This is the link where I refreshed my memory:

 

http://www.noobslab.com/2013/06/open-as-administrator-for-ubuntu.html


Edited by Bezukhov, 15 July 2013 - 10:34 AM.

To err is Human. To blame it on someone else is even more Human.

#3 rburkartjo

rburkartjo

  • Members
  • 3,998 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:03:07 AM

Posted 15 July 2013 - 12:48 PM

you can alway open the terminal type in gksudo nautilus. enter you password. then you can navigate to anything and open. you could also change the permission of the folder permanently by then clicking on the folders properties.


quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#4 EricMon

EricMon
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:03:07 AM

Posted 15 July 2013 - 03:50 PM

AWESOME IT WORKS! Thank you all VERY much!



#5 Bezukhov

Bezukhov

    Bleepin' Jazz Fan!


  • Members
  • 2,698 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Providence, R.I.
  • Local time:04:07 AM

Posted 15 July 2013 - 08:20 PM

Your welcome. I have to admit that rburkartjo's solution is  better than mine.


Edited by Bezukhov, 15 July 2013 - 08:45 PM.

To err is Human. To blame it on someone else is even more Human.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users