Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

this kernel requires an x86-64 cpu but only detected an i686 cpu


  • Please log in to reply
1 reply to this topic

#1 ident

ident

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cambridge
  • Local time:12:54 AM

Posted 13 July 2013 - 06:13 AM

Trying to recover some data off an old old old laptop. it's an amilo****? something. It does not boot up so was asked if i could get some data off. I tried using a live cd (mint 14) but it wont load. Do i need an older version. A little googe said VT must be enabed but i cant find it.

 

Any other ideas?



BC AdBot (Login to Remove)

 


#2 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:54 PM

Posted 15 July 2013 - 09:28 AM

This is usually due to the user trying to use the wrong version of Linux for their hardware, in this case the CPU. (x86, x64, i686, AMD64...)

 

Look for another version to use that supports i686 here; "http://distrowatch.com/search.php?architecture=i686"

 

 

I also used your title as a google search string and found this; "https://hereirestinremorse.wordpress.com/virtualbox/this-kernel-requires-an-x86-64-cpu-but-only-detected-an-i686-cpu-unable-to-boot-please-use-a-kernel-appropriate-for-your-cpu/"

 

This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot – please use a kernel appropriate for your CPU

An amazing error that i encountered installing Debian into Virtual box…its simple enough…mount your iso and install through VBox..

First couple of times, it was just the install screen and nothing i can move..obviously no mouse, neither the keyboard…as Sriram said, no “Press Any Key to continue.” then i tried out the help option so it had a “Press any key to boot…” so i pressed enter as we all do…and i got the error, and i so not have a screen shot for you but it went (but very similar to this) :459009035.jpg

 

“This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot – please use a kernel appropriate for your CPU”

Asking around, i jumped to the conclusion that VBox doesn’t support 64bit OS. So sat and downloaded the x86 cd iso. And mounted it and went allover again…:) guess what?

“This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot – please use a kernel appropriate for your CPU”

Googling i found out that there is something called Intel Virtualization Technology, and AMD V, for those respective boards…so its needs to be enabled..i have a Intel board and i kept thinking this was enabled…of-course it wasnt..

 

Where can you enable it from?

Its in the BIOS…press ‘esc’ when you see the Vendor logo and you will reach the pre boot screen from where you can choose the bios..browse around, find Virtualization Technology and Enable it…

 

Im running Debian 64 bit..and it works very fine indeed..

 

Note: Fedora had no such problem..and i found issues online only for Debian variants..ubuntu and such..hmm…

 

SOLUTION: Enable Intel VT-x/AMD-V from BIOS

 

 

Hope this helps or at least points you to the real issue.

 

Regards,

Zen






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users