Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SpiceWorks


  • Please log in to reply
15 replies to this topic

#1 KJackson50

KJackson50

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 12 July 2013 - 09:53 AM

I am not able to access spiceworks externally anymore. Before I was able to access it (within the network) anywhere around the office without going into the server by using http://myservername/9675.  Now after a server restart it's not allowing for that.

 

I've tried using port 80 and 443, and even restarting SpiceWorks. Anyone know what could be going wrong?



BC AdBot (Login to Remove)

 


#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 12 July 2013 - 02:23 PM

Can you ping the machine from your desktop? Only thing I can think of is perhaps the firewall is blocking it. Some recommend using an alternative port:

http://community.spiceworks.com/topic/133148-external-access-to-spiceworks

Looking at your url, it's possible you've already done that -- i.e., it's set to port 9675. Try typing in myservername:9675 -- colon instead of slash -- and of course doublecheck to see if, in fact, it has been set to that port.



#3 KJackson50

KJackson50
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 12 July 2013 - 02:50 PM

Sorry, I do use a colon instead of a slash. Also I will look into the firewall as well, but not sure what I'll be looking for. Also I guess I'm just not grasping why a simple restart would cause this.

 

I would also like to point out that I have SW on my mobile phone, and it is not working on there either. So will it still be a firewall setting even if it's doing the same thing on two different devices?

 

Right now I'm thinking there is some sort of configuration that changed which is causing this.


Edited by KJackson50, 12 July 2013 - 02:51 PM.


#4 sflatechguy

sflatechguy

  • BC Advisor
  • 2,244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 12 July 2013 - 02:53 PM

Make sure that port is open in your firewall, and that it's not blocking traffic to or from that port.

It's been known to happen. A restart shouldn't affect it, but it may have reset the firewall as that port isn't normally open.



#5 KJackson50

KJackson50
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 12 July 2013 - 02:54 PM

I tried a "netstat -aon" and didn't see that 9675 or 9676 was being used. Am I missing something?

 

Thanks for your prompt responses by the way!



#6 sflatechguy

sflatechguy

  • BC Advisor
  • 2,244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 12 July 2013 - 03:04 PM

You're welcome. Just happened to be at the computer when you posted.

Netstat is only going to show active connections. So if no one is connected to the server, there won't be any traffic for netstat to find.

Make sure all your firewalls, on the server and your routers, are allowing traffic on that port.



#7 KJackson50

KJackson50
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 12 July 2013 - 03:13 PM

Stupid question: How do I do that exactly?

 

I've checked the firewall through control panel and everything looks normal



#8 sflatechguy

sflatechguy

  • BC Advisor
  • 2,244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 12 July 2013 - 03:51 PM

You're going to want to create an exception rule to your firewall and add the port number. You'll create an exception for each port you'll be using.

How you do that depends on what your server OS is. I'm assuming it's Windows. You would go to Control Panel, and use the Advanced Settings. Click on Inbound Rules and create a new rule.



#9 KJackson50

KJackson50
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 15 July 2013 - 10:26 AM

Would that cause any security issues?

 

I'm just a little confused on how this all could have happened, before all I had to do was find the correct url and port to access SW on a networked computer. I will try this and let you know what happens.



#10 KJackson50

KJackson50
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 15 July 2013 - 10:42 AM

Tried that on firewall, no luck.

 

I went ahead and did a diagnosis on the webpage, I received an error saying "MYSERVERNAME is online but isn’t responding to connection attempts"

 

what could this be?



#11 sflatechguy

sflatechguy

  • BC Advisor
  • 2,244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 15 July 2013 - 01:58 PM

It won't create any more security issues than having ports 80 or 443 open. If ports 9675 or 9676 aren't open, you won't be able to communicate with the server at all.

Are you using HTTP or HTTPS? Make sure the firewall exceptions specify the proper connection type. Also, make sure those ports are open on the server, the client, and any routers that may be in between them. Those ports aren't normally open (a good thing, from a security perspective) so any of those firewalls might be blocking it.

Can you telnet into the server?

Is there a public IP address for that server? If so, try http://publicIPaddress:9675

Clearly something got reset when the server was restarted, but without more details about your environment (which you may or may not be willing to share), there isn't much more I can offer in terms of diagnostics.


Edited by sflatechguy, 15 July 2013 - 01:59 PM.


#12 KJackson50

KJackson50
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 15 July 2013 - 02:35 PM

okay I looked again, I see 80, 443, 9675, and 9676 as LISTENING. Just as a test I tried switching SW over to port 80 and 443. They continuously loaded without stopping. I was using HTTP before.

 

Unfortunately I can't give you much more system information.



#13 sflatechguy

sflatechguy

  • BC Advisor
  • 2,244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 15 July 2013 - 02:39 PM

That's OK, I understand.

Well, at least we've ruled out the firewall. It has to be one of your server's settings that changed when the server was restarted. If you documented the settings, or can remember them, you'll have to compare them now to what they should be. Outside of that, I can't offer much more.



#14 KJackson50

KJackson50
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:03:17 AM

Posted 15 July 2013 - 02:43 PM

Well you've been a tremendous help! You've helped me rule out the firewall which would have been a pain on my own lol.



#15 sflatechguy

sflatechguy

  • BC Advisor
  • 2,244 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 15 July 2013 - 02:53 PM

You're welcome. And yes, that is something. :thumbup2:  Helps narrow the search, at least.

Good luck.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users