Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem with WLAN Auto-Config


  • Please log in to reply
4 replies to this topic

#1 SubQuantum

SubQuantum

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:04 AM

Posted 08 July 2013 - 02:04 PM

  Hey guys, this is my second post. I've recently completed the exhasting task of going through my msconfig services one by one and rebooting my computer to identify a computer problem on my Acer laptop with Windows 7. Turns out that my WLAN Autoconfig service is the source of the trouble.

 

  When WLAN autoconfig is enabled, I can start up my computer and log in, but I can't do much after that. As soon as I click on an icon or try to open a program, I see the blue loading circle which soon disappears as if I had never clicked an icon. My computer then freezes and I can only open the start menu or move the mouse. These problems all stop when the program is disabled, but then I have no internet connection. Strangely, SafeMode with Networking allows me to go on the internet, but I can't do so in normal mode when the only program disabled is WLAN autoconfig.

 

I would love to know how to repair/remove/reinstall my WLAN autoconfig as I'm sure it is the cause of the problems.

I'd also enjoy knowing exactly why this is occuring and how it could have happened so I can prevent it in the future.

Thanks!

Liam



BC AdBot (Login to Remove)

 


#2 Comptech72

Comptech72

  • Members
  • 78 posts
  • OFFLINE
  •  
  • Local time:06:04 AM

Posted 13 July 2013 - 10:20 AM

If you disconnected everything in msconfig.. you might have disabled a startup for your WLAN.. secondly open task manager click on the processes tab and sort by the largest about of memory used. otherwise I would run a virus scan to see if there is any thing causing the slowness in normal mode



#3 sikntired

sikntired

  • Members
  • 957 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:06:04 AM

Posted 13 July 2013 - 10:29 AM

This may be of interest: http://bucarotechelp.com/computers/wintips/89051003.asp



#4 IndiEagle

IndiEagle

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:04 PM

Posted 08 July 2016 - 07:07 AM

Hi Liam,
How did you find the solution? I am having almost similar problem. After exhausting work of checking all services in msconfig, I figured out that wlan autoconfig is problem maker. If I stop it, my computer runs normal but without internet, of course. If I enable this service, it just leads to infinite cycle of starting windows and opening blue screen saying windows was not shut down properly until I go to safe mode.
Please share how you solved it as your problem is the only one I found similar in my endless search over internet.

#5 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:02:04 PM

Posted 08 July 2016 - 07:17 AM

If you are not using wireless connection you can disable the WLAN AutoConfig  service which provides the logic required to configure, discover, connect to and disconnect from a wireless local area network (WLAN) as defined by IEEE 802.11 standards. It also contains the logic to turn your computer into a software access point so that other devices or computers can connect to your computer wirelessly using a WLAN adapter that can support this. Stopping or disabling the WLANSVC service will make all WLAN adapters on your computer inaccessible from the Windows networking UI. It is strongly recommended that you have the WLANSVC service running if your computer has a WLAN adapter. Your issue i'm sure not with WLAN AutoConfig  service its wireless card causing the issue install latest version of the wireless card driver.


2GvnEq2.gif





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users