Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't connect to printer via wifi


  • Please log in to reply
10 replies to this topic

#1 wishmd

wishmd

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 07 July 2013 - 11:15 AM

My printer is connected to my home wifi router and also to my desktop via USB. I have two laptops. One with Windows XP and another with Windows 7. The Win7 can go direct to the printer via wifi, no problem. However I cannot get the WinXP laptop to go direct - I have to have the desktop logged on and print jobs are directed to the printer through the desktop. How can I set up the WinXP laptop to go direct to the printer via wifi?



BC AdBot (Login to Remove)

 


#2 SillyMuppet

SillyMuppet

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:01 AM

Posted 07 July 2013 - 11:48 AM

Is it a network printer, or is it a normal printer that is shared across the network via the desktop? My guess it's a network printer but just making sure.



#3 wishmd

wishmd
  • Topic Starter

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 07 July 2013 - 12:37 PM

It is a normal printer that has two connections: one via USB to the desktop, and one directly to the network router. The Win7 laptop directs printing via the network directly to the printer. The WinXP requires that the desktop be turned on - print jobs are directed to the printer through the desktop. That's the part I'm trying to change - I'd like the WinXP printer to print directly through the network (thus not requiring that the desktop computer be logged on), but have been unable to do so. Thanks.



#4 SillyMuppet

SillyMuppet

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:01 AM

Posted 07 July 2013 - 12:52 PM

If you disconnect the usb connection from the printer and then try to add a new network printer on the xp laptop, does it show up? And is the windows 7 laptop still able to print without the desktop being connected at all?

 

Also what is the brand / model of the printer?



#5 wishmd

wishmd
  • Topic Starter

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 08 July 2013 - 12:28 PM

I disconnected the usb. Tried to add a new network printer to the XP laptop - did not work. Kept looking for the the usb printer. But the Win7 still works fine across the network. I have a Brother MFC-5840cn AIO



#6 SillyMuppet

SillyMuppet

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:01 AM

Posted 08 July 2013 - 01:09 PM

Lets see if it gets recognised when you install the drivers for it.

 

- If you go to Start -> Control Panel -> Add / Remove Programs and then uninstall any related drivers / software for the printer. Run through the uninstall wizard and reboot when asked(you can skip this if you haven't installed those in the past)

 

- Then go to http://www.brother.com/html/download/index.htm and click on Printers / Fax Machines / DCPs / Multi-functions under the right region. And click on the country you live in.

 

- Then on the search by model box enter MFC-5840cn then click on search. 1 result should pop up, click on that.

 

- Then go to Downloads -> Select your operating system under Step 1 which should be either Windows XP Home/Professional or Windows XP Professional x64 Edition

 

- Then under Step 2: select the language you want. And click on search at the bottom.

 

- Then under Full Driver & Software Package click on Download & Information and click on the download button.

 

- Then click on I Accept and save it on the desktop. Wait till it's done downloading, it can take a while depending on your internet connection.

 

- When it's done downloading make sure you are logged into a administrator account so you can install software and make a folder on the desktop. You can name it anything you want. Then double click on the exe file and click on run if a window pops up and set the path to the path of your folder you just made by using the browse button. Click on decrompress.

 

- Then double click on the folder you just made and open the Setup5840CN folder. Then open the folder with the language you want, like for example Eng for english.

 

- Then double click on the Setup.exe. It should provide onscreen instructions on what to do. Reboot when asked.

 

I can't test the Setup.exe here sadly enough since i don't have a xp machine along with this printer nearby. If you're unsure about something feel free to make a screenshot and post it here.

 

- When the drivers and software are installed go to Start -> Control Panel -> Devices and Printers and see if it's already in there. If it's in there try and see if it works. If it's not in there try adding a new network printer and see if it gets recognised. If it does add it and see if it works.


Edited by SillyMuppet, 08 July 2013 - 01:40 PM.


#7 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:11:01 PM

Posted 09 July 2013 - 07:00 AM

Also you may try this as well.

 

1 From the Printers folder select Add Printer. The Add Printer Wizard will now start. Click on Next
 

2. Now select the Local Printer option and deselect the Automatically detect and install my Plug and Play printer option.

 

3.Click on Next.

 

4.You must now select the correct Network printing port. Select Create a new port and select Standard TCP/IP Port port from the pull-down window.

 

5.When you have done that click Next.

 

6. The Add Standard TCP/IP Port Wizard will now appear. Click the Next button.

 

7. Enter the IP address, or name of the printer you wish to configure. The Wizard will automatically enter the Port name information for you.

 
8. Click the Next button.
 

9.Windows XP will now contact the printer that you specified. If you did not specify the correct IP address or name then you will receive an error message.

 

10. Click the Finish button to finish the wizard.

 

11. After all of that is done, you will need to install the driver if you don't already have it installed.

 


Edited by chrisd87, 09 July 2013 - 07:01 AM.

"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#8 wishmd

wishmd
  • Topic Starter

  • Members
  • 74 posts
  • OFFLINE
  •  
  • Local time:11:01 PM

Posted 09 July 2013 - 12:48 PM

Chrisd87, that worked perfectly! Thanks very much for the help!



#9 SillyMuppet

SillyMuppet

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:01 AM

Posted 09 July 2013 - 02:36 PM

Glad it's solved :P



#10 pollyjohan

pollyjohan

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:01 AM

Posted 10 July 2013 - 05:18 AM

It is a standard printer that has two connections one via USB to the desktop, and one in a straight line to the network router. If you separate the usb connection from the printer and then attempt to add a new network printer on the xp laptop it will definetly work.

 

<a href="http://www.electrocomputerwarehouse.com>cheap computers</a>



#11 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:11:01 PM

Posted 10 July 2013 - 07:05 AM

Chrisd87, that worked perfectly! Thanks very much for the help!

 

That's awesome, glad it got resolved. Let us know if you need anything else.


"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users