Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cascading routers -- IP addresses conflicting.


  • Please log in to reply
5 replies to this topic

#1 pezmutwal

pezmutwal

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:09 AM

Posted 01 July 2013 - 08:22 PM

I recently installed a new router to an existing network at a local office where I do computer work. This was done mainly to extend the wi-fi to two outdoor trailers (the building's aluminum walls knock down the "main" office's existing wi-fi signal). They already had a range extender in place for the first trailer, but needed the wi-fi to reach the second trailer. However the issue that occurred involved only the LAN connections on each PC, with the wireless connections disabled on all PCs with wireless NIC cards.

 

Here's the setup:

1. A modem somewhere outdoors, on a tower (it's that kind of ISP). Make and model unknown. I didn't bother climbing the tower to check. From there, a CAT-5 cable goes to...

2. The WAN port in Router 1 (the original router), which is a Netgear WNDR3300. IP address: 192.168.1.1. DHCP enabled and set to assign address range 192.168.1.100 - 192.168.1.199. Connected to port 1 is a CAT-5 cable that goes to a 24-port Netgear switch. All of the office PC's are connected to this and configured to "Obtain IP address and DNS server automatically". Connected to port 2 is a CAT-5 cable that goes to...

 

3. Port 1 (not the WAN) in Router 2 (the new router), which is a Belkin F9K1002. IP address: 192.168.1.2. DHCP disabled. Connected to port 2 is a CAT-5 cable that goes to...

 

4. A wi-fi range extender, which is a Linksys WRE54G. IP address: 192.168.1.3. 

 

This setup worked all day on Friday, but Monday morning I received a call from the Office Manager regarding connection issues (involving hard-wired PCs) and some error messages. I went in to investigate and found that nearly every computer was throwing "IP address conflict" errors. My first thought was that maybe, somehow DHCP got enabled on Router 2. This was not the case, DHCP was still disabled. Disconnecting Router 2 from the network instantly solved the "IP address conflict" issue, and reconnecting it instantly caused the issue to start again. 

 

I cannot, for the life of me, figure out what is wrong with the setup that is making that happen. If I left out any necessary information, please do not hesitate to ask.

 

EDIT: Almost forgot, I also tried connecting Router 2 to an open port on the Netgear 24-port switch, instead of directly to Router 1, but the issue persisted.


Edited by pezmutwal, 01 July 2013 - 08:26 PM.


BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,133 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:09:09 AM

Posted 03 July 2013 - 05:55 PM

I would start with finding out if an actual conflict exsist. Is it the Windows PC's that are notifiying you of an error? You can use an Ip scanner such as Advanced IP scanner from radamin. To scan your network and find out exsisting IP addresses (I dont thing it will detect if two computers have the same address). If the network is small enough consider setting all stationary (Lan computers and equipment that doesnt move) to a Static IP address and only leave Wifi computers on DHCP see if the issue persist. 


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#3 pezmutwal

pezmutwal
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:09 AM

Posted 04 July 2013 - 09:18 PM

I would start with finding out if an actual conflict exsist. Is it the Windows PC's that are notifiying you of an error? You can use an Ip scanner such as Advanced IP scanner from radamin. To scan your network and find out exsisting IP addresses (I dont thing it will detect if two computers have the same address). If the network is small enough consider setting all stationary (Lan computers and equipment that doesnt move) to a Static IP address and only leave Wifi computers on DHCP see if the issue persist. 

 

I ran netscan while I was there last time and it listed every PC and piece of equipment that was connected to the network, and showed no conflicts. Curiously, I tried to set all of the PCs and equipment to static IP's, and rebooted the whole network hoping that would eliminate the issue, but it didn't. They STILL got IP conflict errors. Someone else suggested using the "Access Point" option in the configuration page of Router 2. I'm going to try that on Friday, because the only other thing I can think of is that despite DHCP being disabled on Router 2, it's still assigning IP addresses somehow. I'll post an update on afterwards to let everyone know how it goes, that way if someone else has this issue, this thread can help.



#4 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,133 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:09:09 AM

Posted 05 July 2013 - 03:44 AM

Check the event viewer logs to verify where the Warning is coming from. Did you clone any mac addresses? Add any static routes for subnets? Can you post the output of Ipconfig /all from a machine showing a conflict. Router should 2 be set to acess point since its not providing Nat or dhcp. Also check your WAN IP on Router 1 and make sure you don't have a private address on your subnet You could be behind a gateway router from the Isp.
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#5 pezmutwal

pezmutwal
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:10:09 AM

Posted 06 July 2013 - 07:48 AM

That fixed it: Router configuration page --> Set up as an access point, as opposed to "manually" configuring it that way by disabling DHCP.



#6 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,133 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:09:09 AM

Posted 06 July 2013 - 01:31 PM

:thumbup2:


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users