Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Select Operating System to Start


  • Please log in to reply
12 replies to this topic

#1 FedUp2011

FedUp2011

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:01:04 AM

Posted 30 June 2013 - 12:20 PM

Hi folks,

 

I have a minor annoyance whenever I start my computer. The message screen states, "Select Operating System to Start" and since I have Windows XP it always has that twice as my only option to choose and the countdown goes from 25 seconds. If I do nothing it will automotically start once the 25 seconds elapse, or if I manually click on one of the two OS's.

 

Now, I did some digging not too long ago and found that if I go to Start>Control Panel>System>Advanced>Startup and Recover>Settings>Under System Startup>Defaul Operating System>Windows XP Professional>Uncheck "Time to display list of operating systems" and have it set to zero it will (temporarily) fix the problem and bypass the screen, thus speeding up the startup time.

 

But, after a week it seems to revert back to the 25 second countdown and the box is automatically checked again and I have to go back and uncheck it and set it back to zero seconds. Why does this happen? Why aren't the changes saved permanently? Is this just some minor glitch? I don't think it's a virus or spyware as I run checks consistently and haven't found anything at all.

 

Thank you for reading and offering any suggestions!



BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,426 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:04 AM

Posted 30 June 2013 - 12:36 PM

Well...I would just remove the second listing of the O/S, since it seems you only have one.

 

Removing the invalid entries from Boot.ini - http://windowsxp.mvps.org/bootopt.htm

 

Louis



#3 FedUp2011

FedUp2011
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:01:04 AM

Posted 30 June 2013 - 01:13 PM

Thanks, hamlius, for that suggestion. But, would you know why that box, "Time to display list of operating systems" would revert back to being checked a week after unchecking it and setting it to zero seconds? Isn't that unusual in itself? I save the changes and for a week I don't see that message until Sunday (a week after I made the changes). I just find it a bit head-scratching.



#4 hamluis

hamluis

    Moderator


  • Moderator
  • 56,426 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:04 AM

Posted 30 June 2013 - 03:12 PM

The box...not sure if there is such a thing as "0 seconds" :).

 

Windows XP should only be listed once, if you only have 1 install...duplicate boot entries often arise when users try repair installs of XP or partially complete installs before aborting.  The boot files retain the info that was put there, that's why I gave you that link.

 

I generally set mine to 10 seconds (but I dual-boot).  I don't think the timer comes into play when you only have 1 O/S installed.

 

In any case, try setting it to 5 seconds and see if that's fast enough for you.

 

Louis



#5 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:03:04 AM

Posted 30 June 2013 - 05:35 PM

Thanks, hamlius, for that suggestion. But, would you know why that box, "Time to display list of operating systems" would revert back to being checked a week after unchecking it and setting it to zero seconds? Isn't that unusual in itself? I save the changes and for a week I don't see that message until Sunday (a week after I made the changes). I just find it a bit head-scratching.

 

 

Did you click Apply when you made that change? Plenty of folks forget to do that.



#6 FedUp2011

FedUp2011
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:01:04 AM

Posted 30 June 2013 - 11:23 PM

Thanks, Louis. I actually set it to 1 second instead of unchecking the box and having it at zero. We'll see if it saves and doesn't revert back in a week's time.

 

Frankp316, actually there is no Apply button, only the Okay button. Once I click Okay there I'm back to the Advanced tab and while Apply is there (along with Okay and Cancel), I cannot click on it as it is faded out, so I just click on Okay. You'd think the Apply button would be able to be clicked on, right?



#7 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:03:04 AM

Posted 01 July 2013 - 08:55 PM

I don't think the timer comes into play when you only have 1 O/S installed.


The timer does not come into play if you only have one OS installed.

I know this because even though I have a multiple boot option, my system is setup as if there is only OS install.

In case you are (or anyone else is) wondering, I do this by using separate disk drives for each OS and using the boot menu from the motherboard BIOS. And when I install an OS, I disconnect all other drives so that the Windows (or Linux) installer does not accidentally install/setup the boot manager on the OS drive. I like this because then I don't ever need to mess with boot loaders/managers if I decide to remove an OS. I just either wipe the disk or remove the disk.

#8 FedUp2011

FedUp2011
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:01:04 AM

Posted 07 July 2013 - 11:26 AM

And again, on Sunday, it resets back with the box checked for "Time to display list of operating systems" with the default at 30 seconds. It happens either a week after I set it or only on Sundays that it resets. How strange. I guess a minor nuisance though.



#9 hamluis

hamluis

    Moderator


  • Moderator
  • 56,426 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:04 AM

Posted 07 July 2013 - 05:45 PM

I can think of no reason for settings to change, other than a weak CMOS battery.

 

If the CMOS battery were failing, there would be more troublesome situations than you have revealed in this particular topic...and it is unlikely that problems would appear/occur on a seemingly scheduled basis.

 

Louis



#10 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:03:04 AM

Posted 07 July 2013 - 07:09 PM

I can think of no reason for settings to change, other than a weak CMOS battery.
 
If the CMOS battery were failing, there would be more troublesome situations than you have revealed in this particular topic...and it is unlikely that problems would appear/occur on a seemingly scheduled basis.
 
Louis


I am pretty sure that the "timeout" setting is saved in the boot.ini file, so I don't believe the CMOS battery would impact it.

#11 FedUp2011

FedUp2011
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Local time:01:04 AM

Posted 09 July 2013 - 12:26 AM

Would it be sensible to rule out any spyware/malware? I consistently run scans from different sources but never find anything other than cookies.



#12 Zestypanda

Zestypanda

  • Members
  • 603 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sunny San Diego, California.
  • Local time:03:04 AM

Posted 09 July 2013 - 01:04 AM

Note: removing extra entries in a boot menu and or circumventing the boot selection can prevent you from accessing system recovery in some cases. Sometimes your OEM makes a bootable system recovery partition that is ONLY accessible through the boot selection menu.

Have a question, or just wanna chat? Send me a message. Or add me as a friend.

 


#13 hamluis

hamluis

    Moderator


  • Moderator
  • 56,426 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:04 AM

Posted 09 July 2013 - 10:50 AM

Well...your otiginal topic title...appears to have been resolved.

 

If you wish to initiate a new post in the Am I Infected forum....they can answer questions about the possibility of malware.

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users