Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

2008R2 RDS Terminal Server won't run VBS GPO Login Scripts


  • Please log in to reply
2 replies to this topic

#1 youngguns

youngguns

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:07 PM

Posted 28 June 2013 - 01:55 PM

Hi, we have a vbs login script that needs to run through a gpo to map printers based on a thin client name. This has worked for a long time on our 2003R2 Terminal Servers. If you manually run the script on the 2008R2 RDS server as a domain user or domain admin it works without issues. There is nothing in event viewer to indicate that a script or GPO couldn't run. Group Policy Results shows that the GPO successfully applies to the user and computer. The same GPO is used on 2003 Servers no problem and the GPO points to the login script in sysvol. I have tried numerous other GPO settings to get it to work with no success. I have created a new GPO with same settings and it doesn't work. I have removed and readded the 2008R2 server from the domain and it did not work. I have deleted the user profiles and had it recreate it with no success. Here is the GPO settings i have tried:
1. Run logon scripts visible
2. Run logon scripts synchronous .
3. Wait for network on scripts
4. Remove point and print restrictions
5. No group policy slow detection
6. Attachment manager - specify that vbs be a low risk extension 
This script also has gpo loopback processing enabled with MERGE. These settings are configured in user area but applied to a computer. Again this works on 2003 servers no problem. 
 
Thanks for any assistance, i am running out of ideas! 
 

 



BC AdBot (Login to Remove)

 


#2 youngguns

youngguns
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:07 PM

Posted 28 June 2013 - 02:34 PM

Also i have tried a couple more tests. I had the script throw some error to verify it was actually running and when logging in the error is shown. So it looks like it is running. I have also set it to apply the script on log off to see if windows is loading the script before some printer sysbsystem service but that still did not work. I tried to delay the script 10 seconds through VBS and it will still not map the printers. Again it works no problem when running manually from the share. 


Edited by youngguns, 28 June 2013 - 03:29 PM.


#3 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,133 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:07 PM

Posted 11 July 2013 - 05:33 PM

Have you tried Ts easy print?


Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users