Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Connected to LAN, but no internet access


  • Please log in to reply
15 replies to this topic

#1 muleball

muleball

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 26 June 2013 - 07:58 AM

I am running Windows XP Pro SP3.
 
Yesterday afternoon, I received an alert from AVG that it had caught a threat, but that I needed to restart to remove it.  After restarting, I got a pop up that my LAN connection had limited or no connectivity. It detected when I unplugged the cable and plugged it back in, but while it was plugged in it continued to say limited or no connectivity. When I ran ipconfig, the IP address was 169.254.x.x. After looking at related posts, I tried ipconfig /flushdns and netsh winsock reset, but still no luck. After going into TCP/IP properties and changing from "Obtain an IP address automatically" to "Use the following IP address" and entering a static IP, I am able to connect to shared drives on our server, but still not able to access the internet.
 
I looked at logs in the event viewer, and after the reboot, the following messages were logged:
 
Warning-"Your computer was not able to renew its address from the network (from the DHCP Server) for the Network Card with network address 0017314BC7CF.  The following error occurred:
An operation was attempted on something that is not a socket. . Your computer will continue to try and obtain an address on its own from the network address (DHCP) server."
 
Warning-"Your computer has detected that the IP address 0.0.0.0 for the Network Card with network address 0017314BC7CF is already in use on the network. Your computer will automatically attempt to obtain a different address."
 
Warning-"Your computer has detected that the IP address 192.168.0.135 for the Network Card with network address 0017314BC7CF is already in use on the network. Your computer will automatically attempt to obtain a different address."
 
Error-"The system returned the following unexpected error code:
A socket operation encountered a dead network."
 
Warning-"Your computer was unable to automatically configure the IP parameters for the Network Card with the network address 0017314BC7CF.  The following error occurred during configuration: A socket operation encountered a dead network. ."
 
I don't know if this is related or is just an effect of my issue, but when I try to enable Windows Firewall, it says it is unable to do so.
 
No other computer connected to the network has had any issues.
 
Thanks in advance for any help you may be able to give. If there is any information I need to provide, please let me know.

Edit: Moved topic from Windows XP to the more appropriate forum. ~ Animal

BC AdBot (Login to Remove)

 


#2 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:03:17 PM

Posted 26 June 2013 - 06:13 PM

Have you tried booting into Safe Mode with Networking to see if you can get a network connection there?

#3 muleball

muleball
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 26 June 2013 - 07:28 PM

Yes I did with same results.

#4 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:17 PM

Posted 26 June 2013 - 08:49 PM

It's almost like it removed your driver for your nic. Have u tried to download new drivers to see if that will fix it?


"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#5 muleball

muleball
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 27 June 2013 - 02:39 PM

I downloaded the latest driver, and when I tried to install it, it gave me an error that the version of Intel Pro Network Connections that I have is not able to be upgraded and that I would need to uninstall the driver first. I did that (through Local area Connection Properties/Configure/Driver/Uninstall), and then received the same message when I attempted to install it again. I uninstalled again, and and looked in Add/Remove Programs. I found the entry for "Intel PRO Network Connections Software, but when I click "Change/Remove", nothing happens. Is there something else I need to do?



#6 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:03:17 PM

Posted 27 June 2013 - 04:22 PM

I downloaded the latest driver, and when I tried to install it, it gave me an error that the version of Intel Pro Network Connections that I have is not able to be upgraded and that I would need to uninstall the driver first. I did that (through Local area Connection Properties/Configure/Driver/Uninstall), and then received the same message when I attempted to install it again. I uninstalled again, and and looked in Add/Remove Programs. I found the entry for "Intel PRO Network Connections Software, but when I click "Change/Remove", nothing happens. Is there something else I need to do?


Where did you download the driver from? From the computer or motherboard manufacture's site?

I ask because I am wondering if you have the correct driver. If memory serves, there are a few variations on the Intel Pro chipset.

Edited by smax013, 27 June 2013 - 04:23 PM.


#7 muleball

muleball
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 28 June 2013 - 08:03 AM

I downloaded it from this page http://www.intel.com/support/network/sb/cs-006120.htm after searching for "Intel PRO/1000 PL Network Connection Driver". It had a list of several PRO/1000 adapters, but apparently PL wasn't one of them.

 

After I had uninstalled the driver and attempted to install the one from the page above, it did appear that the driver installed but possibly wasn't updated. Also, if I uninstall the driver and reboot, the connection comes back and shows the driver as being installed in network properties, and that the device is working properly.

 

Question: If the driver for the network adapter was the issue, would I still be able to access network drives and not the internet?

 

Thanks so much for your time, and if I haven't explained any of the steps I have attempted clearly, please let me know.



#8 muleball

muleball
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 01 July 2013 - 03:40 PM

I believe I am lost. I downloaded the Intel Ethernet Connections CD from Intel's website at this address:

https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22283&lang=eng&wapkw=intel+ethernet+connections+cd

 

After extracting to my desktop, and running "Autorun" and "install drivers and software", I again saw a message that the version of network connections is not able to be upgraded, so I would need to uninstall and try again. In the install files for XP, there is a "ProUnstl.exe" file, so I ran that, then tried to run "install drivers and software" again and got the same message that it couldn't be upgraded. "Intel Pro/1000 PL Network Connection Software" is still in my progam list, and it seems I still cannot remove it, however now my network connection is gone, and I cannot connect to the server.


Edited by muleball, 01 July 2013 - 03:42 PM.


#9 muleball

muleball
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 01 July 2013 - 04:42 PM

Okay, I found out my motherboard's make/model, went to Asus' website to download the LAN driver, and installed it without issue. I received the notification that I had limited or no connectivity. I assigned IP addresses, and I can again connect to the server, but cannot connect to the Internet. So I am basically back to where I started.

 

Is there anything else I can try?



#10 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:03:17 PM

Posted 01 July 2013 - 08:39 PM

Okay, I found out my motherboard's make/model, went to Asus' website to download the LAN driver, and installed it without issue. I received the notification that I had limited or no connectivity. I assigned IP addresses, and I can again connect to the server, but cannot connect to the Internet. So I am basically back to where I started.
 
Is there anything else I can try?


It is always best to first try downloading from the computer/motherboard manufacturer's site. That is the best way to ensure you get the correct version for your computer/motherboard.

If you do have the latest driver, then I see three basic possibilities:

1) The ethernet card/chipset is dead/damaged. Getting a new network card and installing would solve this problem if it is the problem. I will note that network cards are generally not that expensive, relatively speaking. So, if you want to try it, it would likely not cost much.
2) Maybe something is screwed up with Windows. This could be solved by re-installing Windows.
3) You are infected with something (i.e. AVG did "throw a fit" after all). For this, you might want to post a thread in the "Am I Infected?" forum to see if they can help you find anything.

#11 muleball

muleball
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 02 July 2013 - 12:00 AM

I'll give it a try, thanks!

#12 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:17 PM

Posted 02 July 2013 - 01:56 PM

Okay, I found out my motherboard's make/model, went to Asus' website to download the LAN driver, and installed it without issue. I received the notification that I had limited or no connectivity. I assigned IP addresses, and I can again connect to the server, but cannot connect to the Internet. So I am basically back to where I started.

 

Is there anything else I can try?

 

Are you referring to a work server?

 

can you do me a favor and post an ipconfig /all log for me?

 

you can send the results to a text file and then copy the file and paste it in here.

 

*Depending on where command prompt is pointing to when open, depends on where the file will be saved*

 

  1. Open up a command prompt.

  2. type ipconfig /all > results.txt

  3. Find the file where it was saved to and open.

  4. Paste the results in your next reply.

 

*Please turn off static ip addressing for this test as it will be helpful to see what ip address you receive with dhcp enabled*


Edited by chrisd87, 02 July 2013 - 01:58 PM.

"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#13 muleball

muleball
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 08 July 2013 - 11:03 AM

Chris,

 

Yes, it is a work server where shared files are located.

 

ipconfig results:

 

 

Windows IP Configuration

 

        Host Name . . . . . . . . . . . . : cox

        Primary Dns Suffix  . . . . . . . : ADPDC1.allenbrand-drews.com

        Node Type . . . . . . . . . . . . : Unknown

        IP Routing Enabled. . . . . . . . : No

        WINS Proxy Enabled. . . . . . . . : No

 

Ethernet adapter Local Area Connection 5:

 

        Connection-specific DNS Suffix  . :

        Description . . . . . . . . . . . : Intel® PRO/1000 PL Network Connection

        Physical Address. . . . . . . . . : 00-17-31-4B-C7-CF

        Dhcp Enabled. . . . . . . . . . . : Yes

        Autoconfiguration Enabled . . . . : Yes

        Autoconfiguration IP Address. . . : 169.254.231.125

        Subnet Mask . . . . . . . . . . . : 255.255.0.0

        Default Gateway . . . . . . . . . :

 

Ethernet adapter Local Area Connection 6:

 

        Media State . . . . . . . . . . . : Media disconnected

        Description . . . . . . . . . . . : 3Com EtherLink XL 10/100 PCI TX NIC (3C905B-TX)

        Physical Address. . . . . . . . . : 00-50-DA-B9-CA-BA

 

I did try installing an NIC (the device shown as Connection 6 above) to see if it was the onboard controller that was bad, but I got the same results.

 

Thanks!



#14 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:17 PM

Posted 08 July 2013 - 03:33 PM

Alright, there is a program that hopefully can fix your connection issues. Have you checked your dhcp server to make sure that there are free ip addresses' that it can hand out?

 

Run this program, and see if it helps your issue.

 

1. Download program from here

 

2. Run the program and then do steps 1,2,3, and 4

 

3. After you have done those steps, click Start Repairs and then click start

 

4. Choose Register System Files, Repair Windows Firewall, Repair Internet Explorer, Repair Hosts File, Remove policies set by infections, Repair Winsock & Dns Cache, Repair Proxy Settings,  Restore Important Windows Services, and set Windows Services to default on startup.

 

5. After all of those steps have been completed, please tell us the outcome.

 

*If you've downloaded new drivers, installed new nic and it's still giving you a fit, makes me think either the system is corrupted, and needs to be repaired, or the dhcp server can't hand you an ip address out because there are none free.*


Edited by chrisd87, 08 July 2013 - 03:35 PM.

"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#15 muleball

muleball
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:17 PM

Posted 09 July 2013 - 09:01 AM

Great news! Back up and running! Sometime after I restarted following step 3, my internet connection returned. I finished running the system and registry backups, and ran through the repairs step, and everything seems to be running perfectly. Thank you so much!!!

 

Here is the log that was created:

 

   Running Repair Under System Account
   Running Repair Under System Account
Starting Repairs...
   Start (7/9/2013 8:29:50 AM)

Register System Files
   Start (7/9/2013 8:29:50 AM)
   Running Repair Under Current User Account
   Running Repair Under System Account
   Done (7/9/2013 8:32:02 AM)

Repair Windows Firewall
   Start (7/9/2013 8:32:03 AM)
   Running Repair Under Current User Account
System error 1060 has occurred.

The specified service does not exist as an installed service.

System error 1060 has occurred.

The specified service does not exist as an installed service.

System error 1060 has occurred.

The specified service does not exist as an installed service.

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

   Running Repair Under System Account
System error 1060 has occurred.

The specified service does not exist as an installed service.

System error 1060 has occurred.

The specified service does not exist as an installed service.

System error 1060 has occurred.

The specified service does not exist as an installed service.

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

   Done (7/9/2013 8:32:07 AM)

Repair Internet Explorer
   Start (7/9/2013 8:32:07 AM)
   Running Repair Under Current User Account
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
   Running Repair Under System Account
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
   Done (7/9/2013 8:34:22 AM)

Repair Hosts File
   Start (7/9/2013 8:34:22 AM)
   Running Repair Under System Account
   Done (7/9/2013 8:34:24 AM)

Remove Policies Set By Infections
   Start (7/9/2013 8:34:24 AM)
   Running Repair Under Current User Account
   Running Repair Under System Account
   Done (7/9/2013 8:34:29 AM)

Repair Winsock & DNS Cache
   Start (7/9/2013 8:34:29 AM)
   Running Repair Under Current User Account
   Running Repair Under System Account
   Done (7/9/2013 8:34:41 AM)

Repair Proxy Settings
   Start (7/9/2013 8:34:41 AM)
   Running Repair Under Current User Account
   Running Repair Under System Account
   Done (7/9/2013 8:34:46 AM)

Restore Important Windows Services
   Start (7/9/2013 8:34:46 AM)
   Running Repair Under Current User Account
   Running Repair Under System Account
   Done (7/9/2013 8:34:50 AM)

Set Windows Services To Default Startup
   Start (7/9/2013 8:34:50 AM)
   Running Repair Under Current User Account
   Running Repair Under System Account
   Done (7/9/2013 8:35:12 AM)

Cleaning up empty logs...

All Selected Repairs Done.
   Done (7/9/2013 8:35:12 AM)
   Total Repair Time: 00:05:22

...YOU MUST RESTART YOUR SYSTEM...
   Running Repair Under System Account


Edited by muleball, 09 July 2013 - 09:03 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users