Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Switch from IDE to AHCI without Bios


  • Please log in to reply
No replies to this topic

#1 surge1223

surge1223

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:27 AM

Posted 24 June 2013 - 02:19 PM

My vaio doesn't have the option to chose achi or ide in it anymore, it used to before Sony updated the bios a year or two back.  Anyways I don't know how to change my start type to achi from within Windows 8.  Here are the relavent registry keys.  I didn't have a StartOverrude in storachi, any one have any ideas? Thanks

 

iastor

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor]
"Type"=dword:00000001
"Start"=dword:00000000
"ErrorControl"=dword:00000001
"Tag"=dword:00000019
"DisplayName"="@oem5.inf,%*PNP0600.DeviceDesc%;Intel AHCI Controller"
"Group"="SCSI Miniport"
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\StartOverride]
"0"=dword:00000003

pciide


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\pciide]
"Type"=dword:00000001
"Start"=dword:00000000
"ErrorControl"=dword:00000003
"Group"="System Bus Extender"
"Tag"=dword:00000012
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\pciide\StartOverride]
"0"=dword:00000003

storahci

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci]
"Type"=dword:00000001
"Start"=dword:00000000
"ErrorControl"=dword:00000003
"Group"="SCSI Miniport"
"Tag"=dword:00000058
"DisplayName"="@mshdc.inf,%storahci_ServiceDescription%;Microsoft Standard SATA AHCI Driver"
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\PnpInterface]
"5"=dword:00000001
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Enum]
"0"="PCI\\VEN_8086&DEV_3B2F&SUBSYS_9067104D&REV_05\\3&11583659&0&FA"
"Count"=dword:00000001
"NextInstance"=dword:00000001

iastorv

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV]
"Type"=dword:00000001
"Start"=dword:00000000
"ErrorControl"=dword:00000001
"Group"="SCSI Miniport"
"Tag"=dword:00000019
"DisplayName"="@iastorv.inf,%*PNP0600.DeviceDesc%;Intel RAID Controller Windows 7"
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV\Parameters]
"queuePriorityEnable"=dword:00000000
"BusType"=dword:00000008
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV\StartOverride]
"0"=dword:00000003


 

 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users