Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Touchpad problem on Dell M5030 Laptop


  • Please log in to reply
9 replies to this topic

#1 SteveinCyprus

SteveinCyprus

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:07:38 AM

Posted 22 June 2013 - 10:19 AM

All of a sudden, I am unable to turn off the Touchpad on this Dell M5030 laptop. I use an external USB wireless mouse and when I'm typing the touchpad gets in the way, and moves the cursor all over the screen. 

The touchpad is manufactured by Alps, and I have installed the latest version of driver - V8.1200.10.217.

In the driver Touchpad settings you are able to turn off the touchpad (by an on-screen switch in the 'Dell Touchpad' settings dialogue in Control Panel) but it doesn't work - the touchpad is still live. At the top of the window, there are pictures of the touchpad and the wireless mouse. If I click on the wireless mouse, the following screen has an option which states 'Disable Touchpad and Pointing Stick when USB mouse is present'. Even with this box ticked, the touchpad refuses to turn off.

I have trawled the Dell website for hours with no help forthcoming (good old Dell).

I am appealing for help in solving this problem.



BC AdBot (Login to Remove)

 


#2 RajathAtDell

RajathAtDell

    Authorized Dell Representative


  • Members
  • 65 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bangalore - India
  • Local time:10:08 AM

Posted 25 June 2013 - 11:31 AM

Hi SteveinCyprus,
 

Inspiron M5030 has a separate key on the keyboard to disable the TouchPad. It is located next to the F12 key on Function keys row with a "X" mark on it. You will need to press this key to enable/disable the TouchPad.

 

You can download the Setup Guide from the following link for further information on this:
http://www.dell.com/support/Manuals/us/en/19/Product/inspiron-15-m5030

 

Please let me know if you need further assistance.


Thanks and Regards,
Rajath N
#iworkfordell


#3 SteveinCyprus

SteveinCyprus
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:07:38 AM

Posted 27 June 2013 - 07:10 AM

Thanks Rajath

 

It would help if I got the model number right - the laptop is a Dell Inspiron 3520. The touch-pad 'off/on' control is on F3 but it does not work, as my problem outlined above.  The Dell Touch-pad software does not work either.

 

Can you help with the problem any further?


Edited by SteveinCyprus, 27 June 2013 - 10:00 AM.


#4 RajathAtDell

RajathAtDell

    Authorized Dell Representative


  • Members
  • 65 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bangalore - India
  • Local time:10:08 AM

Posted 27 June 2013 - 01:48 PM

Hi SteveinCyprus,
 

Thank you for your reply and for providing an update on the status. I suggest you to update the BIOS to the latest version and check if the feature works. You can download the latest BIOS from the following link:
http://www.dell.com/support/drivers/us/en/19/DriverDetails/Product/inspiron-15-3520?driverId=367Y2&osCode=W764&fileId=3153998166&languageCode=en&categoryId=BI
 

You may also run the diagnostics to determine if there is an issue with the Touchpad from the following link:
http://www.dell.com/support/Diagnostics/us/en/19/
 

Please let me know about your findings.


Thanks and Regards,
Rajath N
#iworkfordell


#5 kamalpal19

kamalpal19

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:india
  • Local time:10:08 AM

Posted 27 June 2013 - 05:06 PM

Hello friend,

 

The concern you have been facing is due to the old bios . You need to flash the bios to the latest version. Visit support.dell.com and enter your service tag  after that download the latest available bios firnware and install the same, be aware  do not stop the process. As the usb and the touch pad  uses the same bus and are controlled by southbridge issues can occure. 

 

Try it u will be happy.



#6 SteveinCyprus

SteveinCyprus
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:07:38 AM

Posted 30 June 2013 - 09:45 AM

Thank you Rajath and Kamalpal, but my BIOS is already at Version A05, which is the latest version for Windows 8 64-bit on the Dell website.

 

Any further suggestions would be appreciated.   The PC Doctor Diagnostics all passed OK.

 

Steve


Edited by SteveinCyprus, 30 June 2013 - 10:15 AM.


#7 kamalpal19

kamalpal19

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:india
  • Local time:10:08 AM

Posted 30 June 2013 - 03:39 PM

Hello again,


We all understand these are machines and if we have invented them then there is a definate fix. Well as you are using a dell computer then warranty is the last resort. Contact the tech support and tell them about the problem else you can try backing up the data and refresh the pc.


KamalPal Punia.

#8 RajathAtDell

RajathAtDell

    Authorized Dell Representative


  • Members
  • 65 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bangalore - India
  • Local time:10:08 AM

Posted 01 July 2013 - 08:44 AM

Hi Steve,
 

Thank you for your reply and for providing an update on the status. Please send the system Service Tag via Personal Message, so that I can check the system warranty details and let you know the options available.


Thanks and Regards,
Rajath N
#iworkfordell


#9 RajathAtDell

RajathAtDell

    Authorized Dell Representative


  • Members
  • 65 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bangalore - India
  • Local time:10:08 AM

Posted 04 July 2013 - 08:26 AM

Hi Steve,
 

Thank you for your reply and for provided the requested information. I have verified the warranty status and you will need to restore the system to factory defaults and check if this feature gets enabled. Please follow the steps provided in the link below:
http://www.dell.com/support/troubleshooting/us/en/19/KCS/KcsArticles/ArticleView?c=us&l=en&s=dhs&docid=DSN_362066
 

Note: Restoring your computer to the factory settings will remove all files and programs except those it came with.You will lose all personal files, including photos, emails and programs, if you do not back up your files and data.
 

Let me know your findings.


Thanks and Regards,
Rajath N
#iworkfordell


#10 SteveinCyprus

SteveinCyprus
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:07:38 AM

Posted 08 July 2013 - 02:35 AM

Thank you Rajath

 

I was contemplating whether I really wanted to go down the path of resetting to Factory Default, or put up with the problem. 

 

Funnily enough, I turned on the laptop computer this morning to go through backing everything up and the Touchpad icon had reappeared in my desktop taskbar, when I had previously turned it off. I went into Settings, and the touchpad was turned back on, and the 'tick' was missing from 'Disable Touchpad and Pointing Stick when USB mouse is present'. I re-enabled this option and lo and behold, it has started working perfectly. I am mystified as to what has changed, as there have been no Windows or system updates since my last post.

But all is now well - thanks to everyone for their help.

 

Steve


Edited by SteveinCyprus, 08 July 2013 - 02:36 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users