Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Defender Corrupted


  • Please log in to reply
1 reply to this topic

#1 sshh

sshh

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:37 PM

Posted 02 June 2013 - 02:48 AM

HI there,

 

First time posting here, hope I have picked the correct forum? if not can a mod move for me?

 

Recently had a zeroaccess infection that I am pretty sure I have got rid of following other threads on this forum and others. I was left with no access to defender, windows firewall and security centre. I also have IE9 not being able to download files as it says they have a virus. Firefox I have worked around this by turning off scanning. I also can't unzip zip files using windows (presuming its trying to get defender to scan aswell, unzipped folders are empty) but can with winrar.

 

Windows vista SP2 btw.

 

 

I now have access back to security centre and windows firewall thanks to combofix i think?

 

Still cant get defender to work however, control panel shows it there but icon is missing. When clicked it prompts 'windows cannot acccess the specified device, path or file. You may not have the appropriate permissions to access the item'

 

Can see it in services however it is stopped and when I click start I get 'Windows could not start the windows defender service on local computer. Error 5. Access is denied.

 

I read on another thread that someone was able to get defender running again by replacing the program files of vista with those from a working vista computer. Just wondering if someone could zip these up for me so I can give it a try? Any other words of wisdom?

 

I should note, I have no earlier restore points to use and dont have an install cd on me.

 

Have scanned/used the following and seem to be getting no more infected files and no more fixes

 

TDSSKiller

RKiller

Malwarebytes anti malware (in safe made aswell)

Eset smart security 5 (in safe mode aswell)

Spybot search and destroy

Super antispyware

 

Combofix

sfc /scannow



BC AdBot (Login to Remove)

 


#2 sshh

sshh
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:37 PM

Posted 02 June 2013 - 05:43 AM

Ok fixed, managed to copy files from a work computer. Seems to be all working again fine.

 

Defender working

Zip files unpack

IE downloads fine

 

Will keep an eye on things and see if any things pops up but hopefully all is well. Just re-running all scans now to make sure all has gone






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users