Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Egalax Touchscreen Issue


  • Please log in to reply
1 reply to this topic

#1 Gus_19

Gus_19

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:09:38 AM

Posted 01 June 2013 - 06:01 PM

I recently installed the touchscreen on my XFR D630. Downloaded and installed the Egalax drivers for the touchscreen. The Touchmon software shows the PS/2 controller installed and device manager lists the Egalax touch filter listed under mice and pointing devices, but I'm not getting any response even touching the screen during calibration.  I understand I will not get certain features if the screen is not registering as HID compliant by Win7. This is the first time installing something like this and I'm wondering if I'm missing something simple here.



BC AdBot (Login to Remove)

 


#2 Gus_19

Gus_19
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:09:38 AM

Posted 03 June 2013 - 02:05 PM

Problem fixed. I knew I needed another male coupling to connect the splice from the monitor, but believed it was only needed for providing power to the backlit display. Once connected and rebooted, the touchscreen was recognized as USB connected and worked flawlessly.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users